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QElectroTech documentation

Basics

Launch QElectroTech on Linux
After installation, Linux allows the user launching applications from many different ways. Below, the most common
ways are explained.

Launch QElectroTech from terminal

To launch QElectroTech using the terminal, the command to be used is:

$ qelectrotech

The command mentioned above blocks the terminal for other processes. If the terminal should be available for other
processes, the command to launch QElectroTech is:

$ gelectrotech &

Note

If the command is not working, list the applications installed and check the name with which QElectroTech has
been installed.

• Ubuntu command: $ apt list --installed

Figure: Splash screen
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Launch QElectroTech from applications menu

As Windows, Linux operative systems allow the user to launch applications from menus and icons. Where to go
depends on the theme and distribution used. Below, some possibilities according some configurations are
mentioned.

• Unity theme: The icon appears at the launcher bar.

• Gnome shell: The icon appears at [Menu], with the rest of applications.

• Gnome Classic: QElectroTech can be started from Applications > Graphics > QElectroTech.

• KDE: QElectroTech can be started from [Menu] at Graphics > QElectroTech.

Once QElectroTech has been launched, the main window looks as follow:

Figure: Main window QElectroTech

Launch QElectroTech on Windows
After installation, QElectroTech can be launched from Windows Start Menu. If the shortcut icon has been created at
the desktop during installation, QElectroTech can also be launched from that icon.

1. Click the Windows [Start] button.

2. Select All Programs.

3. Open QElectroTech program group.

4. Click QElectroTech icon.
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Figure: Splash screen

Once QElectroTech has been launched, the main window looks as follow:

Figure: Main window QElectroTech

Launch QElectroTech on Mac
After installation, QElectroTech can be launched from applications folder.
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Figure: Starting splash screen

Note

For easier access, QElectroTech can be added to the dock. Just open the applications folder and drag
QElectroTech to the dock.

Once QElectroTech has been launched, the main window looks as follow:

Figure: Main window QElectroTech

QElectroTech help menu
QElectroTech has been designed with some tools which help the user and makes easier the searching of
information. All those tools can be found at Help menu from menu bar.

Figure: Help menu QElectroTech
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Tooltips

To support the user, tooltips are displayed when the mouse arrow is placed on an icon from the toolbars. A tooltip is
a short message which defines the action corresponding to the icon.

QElectroTech also allows the display from tooltips, or short descrition panels, at many different areas and objets from
the main window. These panels are not diplayed automatically with the placement of the mouse arrow on the object
or area.

1. Select Help > What’s this? menu item.

2. Press on the object or area to display the description panel.

Figure: Message which appears at the workspace

To increase the working eficiency, the description panel can also be displayed using keyboard shortcut. The user
does not need to resort to the Help menu.

1. Press shift + f1.

2. Press on the object or area to display the description panel.

Note

The tool What’s this? does not give the description from everyting, it gives only the description for the different
type of collections (title blocks and elements), the workspace, project area and a few objects and areas more.

About QElectroTech

Many information related to QElectroTech can be found at the application without searching on Internet. Everybody
who launch the application can find the license text, version of the application launched, developers and
collaborators.

1. Select Help > About QElectroTech menu item to display the PopUP window with the basic information
from QElectroTech project.

Online Manual

Help menu can address the user to the official online documentation.

1. Select Help > Online Manual menu item to open the official QEletroTech online documentation at default
browser.

When the application is active on the computer, the user can also open the online manual at default browser using
keyboard shortcut.

1. Press f1 to open the official online manual on the browser.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Youtube Channel

Many different video tutorials about QElectroTech can be found on Internet. Help menu can address the user to the
official Youtube channel of the project.
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1. Select Help > Youtube Channel menu item to open the QEletroTech Youtube channel at default browser.

Support the project

If the user is satisfied with the work already made by the developer team from QElectroTech and he wants to help
the project with an economical donation, Help menu can address the user to the official PayPal account of the
project.

1. Select Help > Support the project with a donation menu item to open the official PayPal account from
QEletroTech at default browser.

About Qt

QElectroTech has been designed using Qt framework and widget toolkit. Help menu allows going to the official web
from Qt project without the need of searching on Internet.

1. Select Help > About Qt menu item to open the offical web from Qt at default browser.

Quit QElectroTech
The user can quit QElectroTech at anytime. The user does not need to close the project before clossing the
application.

If the current work wants to be saved before closing the project, refer to save project section. Even so, QElectroTech
displays an automatic message to save the current job if any modification has been created.

Figure: QElectroTech Save message

As a large amoung of applications which has been developed using Qt, QElectroTech can be closed from the close
tab  which can be found at top right from main window, from menu bar or using the corresponding keyboard
shortcut.

Quit QElectroTech from menu bar

1. Select File > Quit menu item to quit QElectroTech.

Figure: QElectroTech File menu

Quit QElectroTech using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + q to quit QElectroTech.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.
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Interface

Interface elements
QElectroTech has been designed using Qt framework and widget toolkit. The main window from QElectroTech is the
same for all platforms where it is available (Windows, Linux/Unix and MacOS). The main window from QElectroTech
contains the following areas:

1. Menu bar

2. Toolbars

3. Workspace

4. Panels

5. Project tabs bar

6. Folio tabs bar

7. Help bar

8. Search Menu

Figure: QElectroTech main window

Menu bar
The menu bar is placed at top from QElectroTech interface. QElectroTech contains the menus File, Edit,
Project, Display, Settings, Windows and Help. Each menu provides many diferent options.

Note

A brief description of each menu option can be read from help or information tool bar by hovering over the option
with the cursor.

File menu

Interface
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Figure: QElectroTech file menu

Option Function Keyboard shortcut Icon

Latest files Opens a project from history (recently opened files)

New Creates a new Project Ctrl + n

Open Opens an existing project Ctrl + o

Save Saves the current project and all its folios Ctrl + s

Save as Saves the current project with a different file name

Close Closes the current project Ctrl + w

Export Exports the curret folio to another format Ctrl + Shift + 
x

Print Print one or more folio of the current project Ctrl + p

Quit Closes QElectroTech Ctrl + q/
Alt + F4

Edit menu

Figure: QElectroTech edit menu

Option Function Keyboard shortcut Icon

Undo Undoes the previous action Ctrl + z

Redo Restores the undone action Ctrl + y

Cut Puts selected elements into the clipboard Ctrl + x

Copy Copies selected elements Ctrl + c

Paste Pastes elements from the clipboard into the folio Ctrl + v

Select All Selects all elments on the folio Ctrl + a

Select none Deselect all elments on the folio Ctrl + Shift +
 a

Invert selection Inverts selection of elements Ctrl + i

Delete Removes selected elements from the folio Del

Rotate Rotates selected elements and texts Space

Choose texts
orientation

Rotates selected texts to a specific angle Ctrl + Space

Find in the panel Finds the selected element in the collections
panel

Interface
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Edit the selected
object

Displays properties for the selected element /
conductor

Ctrl + e

Group selected
texts

Reset conductors Resets the conductors path ignoring the user
changes

Ctrl + k

Folio properties Edits the properties of the folio Ctrl + l

Add a column Adds a column to the folio

Remove a column Removes a column from the folio

Add a row Adds a row to the folio

Remove a row Removes a row from the folio

Bring to front Brings the selection (s) to front Ctrl + Shift +
 Home

Raise Aproachs the selection (s) Ctrl + Shift +
 Up

Lower Moves away the selection (s) Ctrl + Shift +
 Down

Send backwards Sends in the backwards the selection (s) Ctrl + Shift +
 End

Search / Replace Display Search / Replace panel Ctrl + f

Project menu

Figure: QElectroTech project menu

Option Function

Keyboar
d

shortcut Icon

Project properties Display project properties PopUp window

Add a folio Adds a new folio (drawing sheet) to the active project. Ctrl + 
t

Delete this folio Deletes the active folio (drawing sheet) of the project

Clean project Purges the active project of unused elements and empty
categories and templates

Add a summary Creates an index table for the active project

Add a nomenclature Creates a Bill Of Material (BOM) table for the active project

Export to CSV Generates a .csv file summary of elements used in the active
project according to defined filtering options

Export the list of
names of wires

Generates a .csv file summary of conductors used in the active
project

Launch the terminal
block creation
pluging

Interface
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Export the internal
project database

Generates a SQLite database of the active project

Display menu

Figure: QElectroTech display menu

Option Function
Keyboard
shortcut Icon

Display projects Shows the various opened projects in windows or tabs

Select Allows to select elements

Move Allows to view the folio without modifying it

Display the grid Displays or hidden the grid of folio

Background color
white / gray

Displays the background color of the folio in white or gray

Zoom In Expands the folio Ctrl + +

Zoom Out Shrinks the folio Ctrl + -

Zoom content Adjusts the zoom to display all the content of folio
regardless of context

Ctrl + 8

Fit in view Adjusts the zoom on exactly trhe part of the folio Ctrl + 9

Reset zoom Restores default zoom level Ctrl + 0

Settings menu

Figure: QElectroTech settings menu

Option Function Keyboard shortcut Icon

Display Displays or hides toolbars and panels

Full screen mode Displays QElectroTech in full screen mode Ctrl + Shift + f

Configure
QElectroTech

Allows specifying various parameters for
QElectroTech

Windows menu

Figure: QElectroTech windows menu

Option Function
Keyboard
shortcut Icon

Interface
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Close Closes the current project Ctrl + f4

Tile Adds a new drawing sheet to the active project. (Folio
means drawing sheet)

Cascade Deletes the active drawing of the project

Next Project Activates the next project Ctrl + tab

Previous Project Activates the previous project Ctrl + Shift 
+ Backtab

(Opened Projects) Below Previous Project QElectroTech list all opened
projects to select the active project

Help menu

Figure: QElectroTech help menu

Option Function
Keyboard
shortcut Icon

What’s This? Enquires main menu options Shift + f1

About QElectroTech Displays information about QElectroTech

Online manual Lauches the default browser to the online manual of
QElectroTech

f1

Youtube channel Lauches the default browser on the Youtube channel of
QElectroTech

Support the project
with a donation

Lauches the default browser on the QElectroTech
donation paypal account

About Qt Displays information about Qt library

Toolbars
In addition to the different menus, QElectroTech also provides toolbars. The toolbars are groups of buttons with
icons which initiate accions. In general, these buttons have its counterpart at one of the menus from the menu bar.

Note

To help the user, a tooltip is displayed when the arrow is placed on each button.

Toolbar Tools

Figure: QElectroTech toolbar Tools

The different buttons from toolbar Tools are:

Tool Function Keyboard shortcut Icon

New Creates a new Project

Open Opens an existing project Ctrl + o

Interface
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Save Saves the current project and all its folios Ctrl + s

Save as Saves the current project with a different file name

Close Closes the current project Ctrl + w

Print Print one or more folio of the current project Ctrl + p

Undo Undoes the previous action Ctrl + z

Redo Restores the undone action Ctrl + Shift + 
z

Cut Puts selected elements into the clipboard Ctrl + x

Copy Copies selected elements Ctrl + c

Paste Pastes elements from the clipboard into the folio Ctrl + v

Delete Removes selected elements from the folio Del

Rotate Rotates selected elements and texts Space

Note

Select Settings > display > Tools menu item to display or hidden the toolbar Tools.

Toolbar Display

Figure: QElectroTech toolbar Display

The different buttons from toolbar Display are:

Tool Function
Keyboard
shortcut Icon

Select Allows to select elements

Move Allows to view the folio without modifying it

Display the grid Displays or hidden the grid of folio

Background color
white / gray

Displays the background color of the folio in white or gray

Zoom content Adjusts the zoom to display all the content of folio regardless
of context

Ctrl + 8

Fit in view Adjusts the zoom on exactly trhe part of the folio Ctrl + 9

Reset zoom Restores default zoom level Ctrl + 0

Note

Select Settings > Display > Display menu item to display or hidden the toolbar Display.

Toolbar Diagram

Figure: QElectroTech toolbar Diagram

The different buttons from toolbar Diagram are:
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Tool Function
Keyboard
shortcut Icon

Folio properties Edits the properties of the folio Ctrl + l

Reset conductors Resets the conductors path ignoring the user
changes

Ctrl + k

Automatic creation
conductor

Using the automatic creation of conductor (s)
when possible

Note

Select Settings > Display > Diagram menu item to display or hidden the toolbar Diagram.

Toolbar Add

Figure: QElectroTech toolbar Add

The different buttons from toolbar Add are:

Tool Function Keyboard shortcut Icon

Add a textfield Adds a text field to the current folio

Add a picture Adds an image to the current folio

Add line Adds a line to the current folio

Add a rectangle Adds a rectangle to the current folio

Add an ellipse Adds an ellipse to the current folio

Add a polygon Adds a polyline to the current folio

Note

Select Settings > Display > Add menu item to display or hidden the toolbar Add.

Toolbar Depth

Figure: QElectroTech toolbar Depth

The different buttons from toolbar Depth are:

Tool Function Keyboard shortcut Icon

Bring forward Brings the selection (s) to front Ctrl + shift + H
ome

Raise Aproachs the selection (s) Ctrl + shift + U
p

Lower Moves away the selection (s) Ctrl + shift + D
own

Send backwards Sends in the backwards the selection (s) Ctrl + shift + E
nd
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Note

Select Settings > Display > Depth menu item to display or hidden the toolbar Depth.

Workspace
The workspace, also named graphical editor, is the area where the diagrams, schematics and reports (index table,
component list, symbol glosary, etc.) are created.

The QElectroTech workspace looks as follow:

Figure: QElectroTech Workspace

Panels

Projects panel

The projects panel displays the opened projects trees, folios and embedded title blocks. The QET and user collection
title blocks are also displayed at the projects panel.

Figure: QElectroTech Projects panel

To display or hidden the projects panel:

1. Select Settings > Display > Projects menu item.

The tasks which can be done from projects panel are:

• Manage folios (Add folios, define folio order at each project, etc.).

• Manage the embedded title blocks from the project.

• Manage the default QET title block collection.

• Manage the user title block collection.

• Define the active project.

• Define the active folio which should be displayed at the workspace.

• Display the folio properties PopUP window.

• Display the project properties PopUP window.

To make easier the work with the project panel, QElectroTech provides a filter. All folios, projects and title blocks
without a name or part of a string can be hidden.

Collections panel

The colections panel displays the QET, user and projects element collections.
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Figure: QElectroTech collections panel

To display or hidden the collections panel:

1. Select Settings > Display > Collections menu item.

The main function from the collections panel is to manage elements. The tasks which can be done from collections
panel are:

• Manage user collection (Create, edit and delete elements from the collection).

• Edit elements from project collection.

• Search elements from the project collection at the workspace.

• Import elements from QET or user collection to the project (Add new element to workspace).

To make easier the work with the collections panel, QElectroTech provides a search tool that makes faster finding
elements inside the different collections.

Selection properties panel

The selection properties panel displays the properties from the selecte object. Only the properties from some object
can be displayed at the panel. The selection properties panel can display the properties from:

• Elements

• Some basic objects: line, rectangle, ellipse, polygon and picture.

Figure: QElectroTech selection properties panel

To display or hidden the selection properties panel:

1. Select Settings > Display > Selection properties menu item.

The main function of the selection properties panel is to manage the object properties. At QElectroTech, the object
properties can be different for each object. The main tasks that can be done from the selection properties panel are:

• Manage the properties from the basic geometrical objects (line, rectangle, ellipse and polygon).

• Define the scale from the imported pictures.

• Lock the position of the basic objects (line, rectangle, ellipse, polygon and picture).

• Manage the information from the elements (label, function, manufacturer, article number, order number,
etc.).
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• Manage the text and dynamic text from element symbols.

• Display the general element properties (name, position, dimensions, number of terminals, etc.).

• Manage the element links (cross references).

Auto Numbering Selection panel

The Auto Numbering Selection panel displays the active auto numbering pattern for:

• Folio

• Element

• Conductor

Figure: QElectroTech Auto Numbering Selection panel

To display or hidden the Auto Numbering Selection panel:

1. Select Settings > Display > Auto Numbering Selection menu item.

The main function from the Auto Numbering Selection panel is to manage auto numbering patterns.

• Select the active folio auto numbering pattern

• Select the active element auto numbering pattern

Figure: QElectroTech element pattern selection

• Select the active conductor auto numbering pattern
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Figure: QElectroTech conductor pattern selection

Seealso

For more information about how to use the Auto Numbering Select panel during folio addition, refer to add folio
section.

For more information about how to use the Auto Numbering Select panel during element addition, refer to add
element section.

For more information about how to use the Auto Numbering Select panel during conductor creation, refer to
create conductor section.

Undo panel

The Undo panel displays the history since the last time that the document was saved. Once the project is saved,
undo panel is automatically cleared.

Figure: QElectroTech Undo panel

To display or hidden the undo panel:

1. Select Settings > Display > Undo menu item.

The undo panel is used to return the project to the status after one of the actions made after last save. By one click
on one of the actions listed at undo panel, the project will return to the status after the action choosed at the panel.
While the project is not saved again, the user can go to the different status as many times he wants.

Warning

If you play with the panel, be sure that you are at the correct history status before continue working, saving
project or any irreversible action like delete folio. Once the project is saved or an irreversible action is made, the
history is cleared.

Using the undo panel is interested for:
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• Coming back some steps with a click.

• Recovering an object which was deleted some steps before. The object can be recovered coming back one
step before the elimination, copying the object, coming back to the last history status and pasting the
object.

• Checking the status from the project some steps before.

• Etc.

Projects tabs bar
The different opened projects from QElectroTech can be managed using PopUP windows under the menu bar and
toolbars or using a project tabs bar.

Figure: QElectroTech project tabs bar

Note

• Select Display > Display projects > Using windows menu item to manage the projects by windows.

• Select Display > Display projects > Using tabs menu item to manage the projects by tabs bar.

The project tabs bar allows the following actions:

1. Choosing the active project by simple click on the tab.

2. Closing the project by using the close tab which can be found at the right side from each project tab.

Folio tabs bar
The folio tabs bar can be considered part of the workspace. The folio tabs bar contains one tab for each folio of the
project.

Figure: QElectroTech folio tabs bar

The folio tabs bar allows the following actions:

1. Choosing the active folio by simple click on the tab.

2. Opening the properties PopUP window from an specific folio by double click on the tab.

3. Adding new folio to the project by simple click on the Add folio icon  from right side.

Help bar
The help bar, also known as information bar, is the space below control tabs, the bottom left corner from main
window. It is very useful for beginners of QElectroTech in the way that it gives information about the field that is
pointed by the cursor. A user can learn about a field by simply pointing it with the mouse and reading the information
from help bar.
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Figure: QElectroTech help bar

Seach menu
The search menu allows searching elements, folios or conductors which have a text field or property with an specific
value. The seach menu allows finding automatically an element with a desired label, list the folios from an specific
author, etc.

QElectrotech provides a basic and simple search menu composed by a text box which allows writing the desired
string which should be found and some buttons for closing the menu, actualizing the search and going to next and
previous coincidence.

Figure: QElectroTech search menu

QElectroTech also provides an advanced menu where filters can be defined inside folios, text fields, elements and
conductors trees. The advanced mode also allows replacing actions.

Figure: QElectroTech advanced search menu

To display or hidden the search menu:

1. Select Edit > Search / Replace menu item to display or hidden the search menu at the bottom from the
workspace.

Note

The search menu can also be displayed using Ctrl + f shortcut keyboard.

GUI costumization

Organize toolbars

The QElectroTech GUI allows having many different toolbars switched on to make more friendly the application.

To display or hide toolbars:

1. Select Settings > Display menu item to display the panels and toolbars list.
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2. Click on the different toolbars (Tools, Display, Diagram, Add and Depth) which should be displayed or
hidden.

Figure: QElectroTech Settings > Display menu

All toolbars are placed by default under menu bar, in one row. The user is free reorganizing the toolbars. The
toolbars can be organiced in rows, columns at the left or right side from the workspace or as floating toolbar.

Figure: QElectroTech user interface

To change the organization of toolbars:

1. Left click at the left side from the toolbar.

2. Without releasing the toolbar, move the mouse to the final position.

3. Release the toolbar.
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Figure: QElectroTech toolbars placement

Organize panels

QElectroTech GUI has been designed to work using the menu bar and panels. The menu bar is fixed at top. The
panels can be displayed and hidden.

To display or hide panels:

1. Select Settings > Display menu item to display the panels and toolbars list.

2. Click on the different panels (Projects, Collections, Undo, Selection properties and Auto numbering
Selection) which should be displayed or hidden.

Figure: QElectroTech Settings > Display menu

All panels can be displayed at right and left side from workspace. The panels can be organized on column or by tabs.
The panels can also be displayed as PopUp/floating windows.
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Figure: QElectroTech user interface

To change the organization of panels:

1. Left click at the title bar from the panel.

2. Without releasing the panel, move the mouse to the final position.

3. Release the panel.

Figure: QElectroTech panels placement

Project visualization

There is two different ways to manage the activation and hidden of opened projects. The projects can be organized
with a project tabs bar displayed at top from the folio tabs bar or with floating windows that can be displayed or
minimized.

To define the project visualization preference:
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1. Select Display > Display projects menu item to display the project visualization options.

Figure: QElectroTech Display > Display projects menu

2. Click on the desired option: using windows or using tabs

Figure: QElectroTech projects visualization using windows

Seealso

The project display preferences can also be defined at QElectroTech appearance settings.

Full screen mode

QElectroTech provides the option of displaying full screen. The full screen mode can be selected from menu bar and
using keyboard shortcut.

Full screen mode from menu bar

1. Select Settings > FullScreen Mode menu item to display QElectroTech in full screen mode.

Figure: QElectroTech settings menu

Full screen mode using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + Shift + f to display QElectroTech in full screen mode.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.
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Note

To leave full screen mode, select Settings > Leave FullScreen Mode menu item or use again
Ctrl + Shift + f keyboard shortcut.

Preferences

Display settings
QElectroTech allows the user customizing many settings: language, appearance, export and printing settings,
pre-define new project settings, element collection paths, etc.

To display QElectroTech settings:

1. Select Settings > Configure QElectroTech menu item.

Figure: QElectroTech settings menu

QElectroTech appearance

Project visualization

The defaul project visualization option can be defined at the appareance settings from QElectroTech. Select
between:

• Use windows

• Use tabs

Note

The changes are applied at the next launch, quit and launch again QElectroTech or follow the procedure from
customize project visualization.

Figure: QElectroTech appearance settings
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Project settings

Figure: QElectroTech general project settings

Element settings

Figure: QElectroTech elements settings

Collection settings

QElectroTech allows choosing the path from the QET (Common) and User element collection. The path from User
Title Block collection can also be choosed. The collections directory can be at the local Hard Disk, common users, or
at local servers, common for companies.

The default element collection paths depend on the installation settings choosed during the installation process.
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Example

QET
collection:

Windows: C/Program Files/QElectroTech/elements

Linux: /usr/share/qelectrotech/elements

Mac:

User
collection:

Windows: C/users/user_name/Application Data/qet/elements

Linux: /Home/user_name/QElectroTech/collections/elements

Mac:

For changing the element collection paths of QElectroTech:

1. Display QElectroTech settings PopUP window.

2. Go to Elements section.

3. Search and choose the folder directory from the QET (Common) and User element collection at the
Collection of elements section.

4. Press OK button to save the configuration changes and close settings PopUP window.

Note

QElectroTech has to be restarted to implement the changes.

Element management settings

QElectroTech provides the posibility to predefine the element author. In this way; when a new element is created,
QElectroTech defines automatically this element property.

For pre-defining the element author information:

1. Display QElectroTech settings PopUP window.

2. Go to Elements section.

3. Defines the element author and license information at the text box from Elements management section.

4. Press OK button to save the configuration changes and close settings PopUP window.

Select language
QElectroTech is a multilanguage tool already translated to 21 languages.

To select the working language:

1. Display QElectroTech settings PopUP window.

2. Go to General section.

3. Go to Language tab.

4. Spread out the combo box and select the desired language.

5. Press OK button to save the configuration changes and close settings PopUP window.

Note

The changes are applied at the next launch, quit and launch again QElectroTech.
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Figure: QElectroTech configure language section

Text settings
Before starting to work, QElectroTech allows defining the default appearence of the different texts.

Elements texts

Independent texts

QElectroTech allows defining a default orientation and text font from the text field object.

1. Click at the button from the text font to display the select font PopUp window.

2. Select a default rotation angle for the text.

Note

Oposite to the geometrical angle, QElectroTech use the clock direction to define angles.

Figure: QElectroTech dynamic texts settings

Preferences

27

file:///home/hude/Documents/github/annex/text_font.html


Summary pages

QElectroTech allows defining a default text font from the project summary table.

1. Click at the button from the text font to display the select font PopUp window.

Other texts

QElectroTech allows defining a default orientation and text font for the text that is not part from an element, text field
object and from the project summary.

1. Click at the button from the text font to display the select font PopUp window.

Figure: QElectroTech dynamic texts settings

Grid settings
QElectroTech provides a grid displayer for the workspace which makes easier the drawing work.

To configurate the grid displayed:

1. Display QElectroTech settings PopUP window.

2. Go to General section.

3. Go to Grid + Keyboard tab.

4. Define the X and Y pixels of the grid cell. The cell size can be between 1 and 30 pixels.

The number of grid cells displacement using the keyboard or the scroll bar can also be defined at the same section
where the grid characteristics are defined. Standar and accurat scroll (with ALT key) can be defined.

Seealso

To display the grid at the workspace, refer to toolbars section.
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Figure: QElectroTech grid settings

New project settings

Folio settings

QElectroTech provides the option to storage at the Data from the application some project properties pre-defined by
the user. This feature allows the user avoiding to define many project properties each time that the user creates new
projects.

The Folio tab from New project settings section allows pre-defining some folio properties:

• Folio size.

• Folio title block.

• Folio default variables values.

• Folio user variables.
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Figure: QElectroTech New project folio settings

To define folio settings:

1. Display QElectroTech settings PopUP window.

2. Go to New project section.

3. Go to Folio tab.

4. Define the desired parameters for each field.

5. Press OK button to save the configuration changes and close settings PopUP window.

Note

All pre-defined folio properties defined at QElectroTech settings PopUP window will be automatically defined
during project creation at project properties. The folio properties can be found at Folio tab from New folio section.

Conductor settings

QElectroTech provides the option to storage at the Data from the application some project properties pre-defined by
the user. This feature allows the user avoiding to define many project properties each time that the user creates new
projects.

The Conductor tab from New project settings section allows pre-defining some conductor properties:

• Conductor type (Multiline or Single line).

• Conductor appearance.

Figure: QElectroTech New project conductor settings

To define conductor settings:

1. Display QElectroTech settings PopUP window.
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2. Go to New project section.

3. Go to Conductor tab.

4. Define the desired parameters for each field.

5. Press OK button to save the configuration changes and close settings PopUP window.

Note

All pre-defined conductor properties defined at QElectroTech settings PopUP window will be automatically
defined during project creation at project properties. The conductor properties can be found at Conductor tab
from New folio section.

Folio referencings settings

QElectroTech provides the option to storage at the Data from the application some project properties pre-defined by
the user. This feature allows the user avoiding to define many project properties each time that the user creates new
projects.

The Folio referencings tab from New project settings section allows pre-defining the formula which should define
the label variable from Reference folio following and Previous reference folio.

Figure: QElectroTech New project folio referencings settings

To define folio referencings settings:

1. Display QElectroTech settings PopUP window.

2. Go to New project section.

3. Go to Folio referencings tab.

4. Define the desired parameters for each field.

5. Press OK button to save the configuration changes and close settings PopUP window.
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Note

All pre-defined folio referencings properties defined at QElectroTech settings PopUP window will be automatically
defined during project creation at project properties. The folio referencings properties can be found at Folio
referencings tab from New folio section.

Cross references settings

QElectroTech provides the option to storage at the Data from the application some project properties pre-defined by
the user. This feature allows the user avoiding to define many project properties each time that the user creates new
projects.

The Cross references tab from New project settings section allows pre-defining some cross references properties:

• Cross references type (Coil, organ of protection or Switch/button).

• Cross references label

• Representation position cross references label (Under the label of the element or Footer).

Figure: QElectroTech New project cross references settings

To define cross references settings:

1. Display QElectroTech settings PopUP window.

2. Go to New project section.

3. Go to Cross references tab.

4. Define the desired parameters for each field.

5. Press OK button to save the configuration changes and close settings PopUP window.
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Note

All pre-defined cross references properties defined at QElectroTech settings PopUP window will be automatically
defined during project creation at project properties. The cross references properties can be found at Cross
references tab tab from New folio section.

Export settings
QElectroTech allows predefining export settings for reducing the working configuration effort each time that a project
have to be exported.

The default exporting settings which can be choosed are:

• Default target directory.

• Default exporting format (PNG, JPEG, Bitmap, SVG or DXF).

• Default rendering options:

• Draw or not borders.

• Title block.

• Draw grid.

• Draw terminals.

• Keep conductor colors or monochrome.
To define default export settings:

1. Display QElectroTech settings PopUP window.

2. Go to Export section.

3. Select the desired setting values for each field.

4. Press OK button to save the configuration changes.

Figure: QElectroTech export settings

Seealso

For more information about QElectroTech export options, refer to export section.
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Printing settings
QElectroTech allows predefining printing settings for reducing the working configuration effort each time that a
project have to be printed.

The default exporting settings which can be choosed are:

• Default rendering options:

• Draw or not borders.

• Title block.

• Draw grid.

• Draw terminals.

• Keep conductor colors or monochrome.
To define default printing settings:

1. Display QElectroTech settings PopUP window.

2. Go to Printing section.

3. Select the desired setting values for each field.

4. Press OK button to save the configuration changes.

Figure: QElectroTech printing settings

Seealso

For more information about QElectroTech printing options, refer to printing section.

Project

What is a project?
The term project inside QElectroTech can be assimilated to a “dababase”. A project is not a common database, it is a
collection of information which is not structurated in columns and rows.

Figure: QElectroTech project structure
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A project is a group of folios, elements and conductors represented inside the folios with the respective properties,
properties which define the way how should be represented each folio (title block, dimensions, etc.), properties which
define how the reports should be represented (folio index, component list, connector list, etc.), properties which
define how to export or print the information, interconnection relaction between elements from the same or different
folios and the master data (project name, author, year of creation, revision, etc.).

The project is the base of QElectroTech to manage a work. The development team has focus the tasks on the
electrical and control filed, even so, QElectroTech is a E-CAE software. For this reason, QElectroTech is an
inter-disciplinary tool that allows the user to create many type of projects.

• Electrical projects: Purely electrical systems

• Automation projects: GRAFCET, diagrams, etc.

• Fluid power projects: Hydraulic, pneumatic and central lubrication systems

• Proces control projects: Proces Industrial Diagrams (PID)

Create new project
A new project can be created from menu bar, toolbar and using the corresponding keyboard shortcut.

Create new project from menu bar

1. Select File > New menu item to create a new project.

Figure: QElectroTech file menu

Create new project from toolbar

1. Select the icon  from toolbar to create a new project.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools

Create new project using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + n to create a new project.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Open Project
Opening a project saved somewhere from the computer Hard Disk or local server can be done from menu bar,
toolbar and using the corresponding keyboard shortcut.
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A project is conformed by a simgle file with .qet format. The .qet extension is the native extension from
QElectroTech. Even so, QElectroTech allows also working with Extensible Markup Language files, files with
extension .xml.

Open project from menu bar

1. Select File > Open menu item to open the search file PopUP window.

Figure: QElectroTech file menu

2. Search the project in the computer

3. Press Open button to close the search file PopUP window and open the project.

Open project from toolbar

1. Select the icon  from toolbar to open the search file PopUP window.

2. Search the project at the computer

3. Press Open button to close the search file PopUP window and open the project.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools

Open project using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + o to open the search file PopUP window.

2. Search the project at the computer

3. Press Open button to close the search file PopUP window and open the project.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Files history

When QElectroTech has already been used, exists the posibility to open a project created, opened and/or saved
previously. File History has been integrated.

1. Select File > Latest files menu item to display the file history from QElectroTech.

2. Click on the project file that should be opened.
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Figure: QElectroTech File History

Save Project
The current project can be saved from menu bar, toolbar and using the corresponding keyboard shortcut.

One project is conformed by a simple file with .qet format. The .qet extension is the native extension from
QElectroTech.

Save project from Menu bar

1. Select File > Save menu item to save the active project.

At the case that the project has already been saved and wants to be saved as a different project, different name
and/or directory:

1. Select File > Save as menu item to save the active project as a new project.

Save project from toolbar

1. Select the icon  from toolbar to save the active project.

At the case that the project has already been saved and wants to be saved as a different project, different name
and/or directory:

1. Select the icon  from toolbar to save the active project as a new project.

Note

If the toolbar is not displayed, it can be displaed from Settings > Display > Tools

Save project using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + s to save the active project.
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Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Note

QElectroTech allows creating backup from project periodically. This option should be configurated at Settings >
Configure QElectroTech > Projects.

Open project underlying directory
QElectroTech provides the feature of opening the directory where a opened project was saved from the user
interface, without the need to look for the directory locally.

To open the underlying directory of a project:

1. Right click on the opened project from which the underlying directory is desired from the projects panel
tree.

2. Select Open the underlying directory to open the local directory where the project was saved.

Figure: QElectroTech project options in projects panel

Note

If the projects panel is not displayed, it can be displayed from Settings > Display > Projects.

Close Project
The user can close a project at any time. If the current work wants to be saved before closing the project, refer to
save section. Even so, QElectroTech display an automatic message to save project if any modification has been
created on it.

Figure: QElectroTech Save message

Closing the current project can be done from menu bar, toolbar, projects panel, projects tab bar and using the
corresponding keyboard shortcut.

At the case that more than one project are opened, the active project will be the project which will be closed.

Close project from menu bar

1. Select File > Close menu item to close the active project.
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Figure: QElectroTech File menu

Close project from toolbar

1. Select the icon  from toolbar to close the active project.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

Close project from projects panel

The advantage of clossing projects from projects panel is the posibility to close projects which are opened and are
not the active project.

1. Right click on the opened project from the projects panel tree wich should be closed.

2. Select Close this project to close the selected project.

Figure: QElectroTech projects panel

Note

If the projects panel is not displayed, it can be displayed from Settings > Display > Projects.

Close project from projects tabs bar

All opened projects can be visible at the projects tab bar that is displayed at top from the workspace. The user can
close an opened projects, regardless of whether the project is active, with a click on the close tab  from the project
tab.

At the case that the projects are displayed as PopUP windows, they can be closed with a click on the close tab 
which is placed at the top right corner.

Note

Displaying the projects using a tab bar or using PopUP windows can be choosed at Display > Display projects.

Close project using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.
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1. Press Ctrl + f4 to close the active project.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Clean project
QElectroTech stores on the project database every title block, conductor, element, etc. which is introduced by the
user. If the user deletes one element or replace the title block from the folio, the element or title block will be deleted
from the folio but it will still be storage at the project database.

QElectroTech allows cleaning the project database from menu bar.

1. Select Project > Clean project menu item to open the cleaning project PopUP window.

Figure: QElectroTech cleaning project PopUP window

2. Select the check buttons desired (templates, elements, categories).

3. Press the button OK to clean the project and close the cleaning project PopUP window.

Note

Cleaning the project is recomended to reduce the size of the project file and inclease the loading speed.

Project properties

Display project properties

The project properties can be displayed in a PopUP window from menu bar and projects panel.

Project properties from menu bar

1. Select Project > Project properties menu item to display the project properties PopUP window from the
active project.

Figure: QElectroTech project menu

Project

40

file:///home/hude/Documents/github/project/index.html
file:///home/hude/Documents/github/interface/menu_bar.html
file:///home/hude/Documents/github/folio/title_block/index.html
file:///home/hude/Documents/github/conductor/index.html
file:///home/hude/Documents/github/element/index.html
file:///home/hude/Documents/github/element/index.html
file:///home/hude/Documents/github/folio/title_block/index.html
file:///home/hude/Documents/github/folio/index.html
file:///home/hude/Documents/github/element/index.html
file:///home/hude/Documents/github/folio/title_block/index.html
file:///home/hude/Documents/github/folio/index.html
file:///home/hude/Documents/github/interface/menu_bar.html
file:///home/hude/Documents/github/project/index.html
file:///home/hude/Documents/github/project/index.html
file:///home/hude/Documents/project/properties/index.html
file:///home/hude/Documents/interface/menu_bar.html
file:///home/hude/Documents/interface/panels/projects_panel.html
file:///home/hude/Documents/project/properties/index.html


Warning

If more than one projects is opened, be sure that the active projects is the correct before changing properties.

Project properties from project panel

The advantage of displaying the project properties from projects panel is the posibility to choose projects which are
opened and are not the active project.

1. Right click on the project from the tree of the projects panel.

2. Select Project properties to display the project properties PopUP window.

Figure: QElectroTech projects panel

Note

If the projects panel is not displayed, it can be displayed from Settings > Display > Projects.

General properties

The general properties section from project properties PopUP windows is the area where the user can define global
project variables that later on can be used at the folios title block templates to automate the filling of the title block.

Creating general project variables is recomended, it increases the working efficiency. The variables that can be
found by default are:

• % {projecttitle}: Project title

• % {saveddate}: File saving date

• % {savedfilename}: Registered file name

• % {savedfilepath}: Saved file path

• % {savedtime}: File saving time
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Figure: General project properties window

To create a new project variable:

1. Display project properties PopUp window.

2. Go to General project properties section.

3. Define the variable name at the left cell from the last row of the project variables table.

4. Define the value of the variable at the right cell from the variable row.

5. Press the button OK to save the changes and close the PopUp window.

Seealso

For more information about QElectroTech default variables, refer to default QElectroTech variables section.

New folio properties

Folio properties

At QElectroTech, the folio properties can be common at all folios from the same project. QElectroTech also allows
that each folio has its own properties. For example, two folios from the same project will have the same size and title
block but they can be created by different authors or they can have different revision.

To increase the working eficiency, QElectroTech provides the option to storage at the project Data some project
properties pre-defined by the user. This feature allows the user avoiding to define many folio properties each time
that the user creates new folio inside the project.

Note

QElectroTech allows defining automatically folio properties during project creation. For more information about
how to standarize some folio properties from project to project, please refers to the QElectroTech folio settings
section.

The Folio tab from New folio settings section allows pre-defining some folio properties:

• Folio size.

• Folio title block.

• Folio default variables values.

• Folio user variables.
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Figure: Project folio properties window

To define folio properties:

1. Display project properties PopUP window.

2. Go to New folio section.

3. Go to Folio tab.

4. Define the desired parameters for each field.

5. Press OK button to save the configuration changes and close project properties PopUP window.

Note

All pre-defined folio properties at project properties will be automatically defined during folio creation at folio
properties.

Conductor properties

Some conductor properties can be common at all or gran part of conductors from all or gran part of folios. For
example, the conductor type is normally common for a complete project or for a group of folios.

To increase the working eficiency, QElectroTech provides the option to storage at the project Data some project
properties pre-defined by the user. This feature allows the user avoiding to define many conductor properties each
time that the user creates new conductor inside the project.

Note

QElectroTech allows defining automatically conductor properties during project creation. For more information
about how to standarize some conductor properties from project to project, please refers to the QElectroTech
conductor settings section.

The Conductor tab from New folio settings section allows pre-defining some conductor properties:

• Conductor type (Multiline or Single line).

• Conductor appearance.

Figure: Project conductor properties window

To define conductor settings:

1. Display project properties PopUP window.
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2. Go to New folio section.

3. Go to Conductor tab.

4. Define the desired parameters for each field.

5. Press OK button to save the configuration changes and close project properties PopUP window.

Note

All pre-defined conductor properties at project properties will be automatically defined during folio creation at folio
properties.

Folio referencing properties

QElectroTech allows creating schemas with multiple folios, only part of the schmea is represented at each folio. This
means that part of a conductor can be at one folio and the continuation at a different folio.

QElectroTech provides folio referencing elements to indicate from where a conductor is coming or where it is going.
These elements can display at the workspace from the folio some information about the folio referencing element
linked. The iformation which should be displayed can be defiend by the user at Folio referencing tab from New
Folio section of the project properties.

Seealso

For more information about folio referencing, refer to Reference folio following and Previous reference folio.

Figure: Project folio referencing properties window

To define folio referencing Label:

1. Display project properties PopUP window.

2. Go to New folio section.

3. Go to Folio referencings tab.

4. Define the desired parameters for each field.

5. Press OK button to save the configuration changes and close project properties PopUP window.

Cross references properties

The main advantage of using Master and Slave elements is the posibility to create cross references (links) between
elements. At the case of cross references definition, QElectroTech provides the posbility to display automatically at
the workspace some information from the Master or Slave element linked.
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The definition or cross references properties inside a project can be costumized by the user at project properties.

Note

QElectroTech allows defining automatically cross references properties during project creation. For more
information about how to standarize some cross references properties from project to project, please refers to the
QElectroTech cross references settings section.

The Cross references tab from New folio settings section allows pre-defining some cross references properties:

• Cross references Master element type (Coil, organ of protection or Switch/button).

• Cross references label (Master and slave cross references label to be display at the workspace)

• Representation position from the cross references label (Under the element label or Footer).

• Display option from cross references

Note

The cross reference label can be created using the general variables from Master and Slave elements.

Figure: Project cross referencing properties window

To define cross references settings:

1. Display project properties PopUP window.

2. Go to New folio section.

3. Go to Cross references tab.

4. Define the desired parameters for each field.

5. Press OK button to save the configuration changes and close project properties PopUP window.

Note

All pre-defined cross references properties defined at QElectroTech settings PopUP window will be automatically
defined during project creation at project properties. The cross references properties can be found at Cross
references tab tab from New folio section.
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Auto numbering properties

For managing projects during manufacturing, erection, commissioning and maintenance phase; a codification criteria
has to be defined in the engineering phase, otherwise, the work is uneficient and the project a caos.

QElectroTech allows defining auto numbering patterns in the project properties for the codification of elements,
conductors and folios.

Every time that a new folio is added to the project or an element or conductor is drawn in the workspace; the folio,
element or conductor is codificated according to the selected patter in auto numbering selection panel.

Figure: Project management properties window

Display auto numbering properties from menu bar

1. Select Project > Project properties menu item to display the project properties PopUp window.

2. Go to Auto Numbering project properties section.

3. Go to Conductor, Element or Folio tab to display the desired auto numbering patterns.

Display auto numbering properties from panel

The project auto numbering properties can be displayed from auto numbering selection panel.

1. Press  Configure button from auto numbering selection panel to display Auto Numbering project
properties section at a PopUp window.

2. Go to Conductor, Element or Folio tab to display the desired auto numbering patterns.

Note

If the auto numbering selection panel is not displayed, it can be displayed from Settings > Display > Selection
properties.

Seealso

For more information about auto numbering pattern definition refer to:

• Folio numbering section

• Conductor numbering section

• Element numbering section
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Folio

What is a folio?
A folio is part of the project that can be considered as a unit. It can be the project index, part of the schema, the part
list complete or partly, etc.

The folio defines the maximum part of the project information that can be displayed at the same time in the
workspace, a folio from a project is equivalent to a page of a book. When a project is exported to PDF, each folio is
one page from the document. When a project is exported to any other format (PNG, JPG, DXF, etc.), each folio is
one file.

Inside a project, the folios should have an order. For an easy understanding of the schema, it is important that the
user takes care about the position and information that is included at each folio.

Figure: QElectroTech folios

Type of folio

Single line diagram

The single line diagrams represent electric, fluid, etc. systems using a simplified notation.

Single line conductors are used to draw single line diagrams.

Note

At electric schemas, the power system is represended with a simplified notation and the control system is not
represented. The conductors only represent power cables.

At fluid power schemas, the pressure and return line are represented by the same conductor.
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Figure: Single line diagram

Multiline diagram

The multiline diagrams represent electric, fluid, etc. systems including all details: terminals, all phases, power and
control system, etc.

Multiline conductors are used to draw single line diagrams.

Figure: Multiline diagram

Control diagram

A control diagram is a representation of the logic from a system, it is a model of the process to automate considering
inputs, actions to be carried out and the intermediate processes that cause these actions.

Single line conductors are used to draw control diagrams.

Note

QElectroTech can represent processes using IEC 61131-3 standards (Ex.: GRAFCET, Ladder, etc.).
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Figure: Single line diagram

Add new Folio
QElectroTech allows creating folios from menu bar, projects panel, folios tabs bar and using the corresponding
keyboard shortcut.

Add new folio from menu bar

1. Select Project > Add a folio menu item to add a new folio to the active project.

Figure: QElectroTech Project menu

Add new folio from projects panel

1. Right click on the project where a new folio should be added.

2. Click the option Add a folio to add a new folio to the project.
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Figure: QElectroTech Project panel

Note

If the projects panel is not displayed, it can be displayed from Settings > Display > Projects

Add new folio from folios tabs bar

1. Click on the Add folio icon  from right side of the folios tabs bar to add a new folio to the active project.

Add new folio using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + t to add a new folio to the active project.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Delete Folio
QElectroTech allows deleting folios from a project from menu bar and projects panel.

Delete folio from menu bar

1. Select Project > Delete this folio menu item to delete the active folio.

Figure: QElectroTech Project menu

Delete folio from projects panel

1. Right click on the folio which should be deleted.

2. Click the option Delete this folio to delete the selected folio.
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Figure: QElectroTech Project panel

Note

If the projects panel is not displayed, it can be displayed from Settings > Display > Projects

Folio properties

Display folio properties

The folio properties can be common at all folios from the same project. QElectroTech also allows that each folio has
its own properties. For example, two folios can be created by different authors or they can have different revision
item.

Note

To reduce the creation time, QElectroTech allows creating some pre-setting for all future folios that will be
created at the project. For more information about how to pre-define folio properties, refer to project properties
section.

The folio properties window can be displayed from menu bar, workspace, toolbar, projects panel, folios tabs bar and
using the corresponding keyboard shortcut.

Display folio properties from menu bar

1. Select Edit > Folio properties menu item to display folio properties from the active folio.

Figure: QElectroTech Edit menu

Display folio properties from workspace

1. Right click on the workspace area. Should be somewhere without any element, conductor, table, etc.

2. Click the option Folio properties to display folio properties from the active folio.
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Figure: QElectroTech Workspace Menu

Display folio properties from toolbar

1. Select the icon  from toolbar to display folio properties from the active folio.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Diagram.

Display folio properties from projects panel

1. Right click on the folio where any property should be defined, it can be an inactive folio from an inactive
project.

2. Click the option Folio properties to display folio properties from the selected folio.

Figure: QElectroTech Project panel

Note

If the projects panel is not displayed, it can be displayed from Settings > Display > Projects

Display folio properties from folios tabs bar

1. Doble click on the folio tab to display folio properties.

Figure: QElectroTech folio tabs bar

Display folio properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + l to display folio properties from the active folio.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Folio

52

file:///home/hude/Documents/interface/toolbars.html
file:///home/hude/Documents/folio/properties/index.html
file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/interface/toolbars.html
file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/project/index.html
file:///home/hude/Documents/folio/properties/index.html
file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/interface/panels/projects_panel.html
file:///home/hude/Documents/interface/folio_tabs.html
file:///home/hude/Documents/folio/properties/index.html
file:///home/hude/Documents/folio/properties/index.html
file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/interface/menu_bar.html


Folio size

The working area from the workspace is defined as a grid of columns and rows. All columns have the same width
and all rows have the same height.

Figure: QElectroTech folio with 17 columns (0 to 16) and 8 rows (A to H) is shown

The parameters that can be costumized from Dimensions of folio section from the folio properties PopUp window
are:

1. Number of columns.

2. Width from columns.

3. Column headers display or hidden.

4. Number of rows.

5. Height from rows.

6. Row headers display or hidden.

Figure: QElectroTech dimensions of folios section

The version 0.7 from QElectroTech works with pixels and there is no pre-defined folio sizes. The pixels dimensions
according ISO 216 are:

ISO 216

A-

mm pixels

-0 841 x 1189 3178 x 4494

-1 594 x 841 2245 x 3178

-2 420 x 594 1587 x 2245

-3 297 x 420 1122 x 1587

-4 210 x 297 794 x 1122

-5 148 x 210 559 x 794

-6 105 x 148 397 x 559

-7 74 x 105 280 x 397

-8 52 x 74 196 x 280

-9 37 x 52 140 x 196

-10 26 x 37 98 x 140

Seealso

For more information about how to display folio properties, refer to display folio properties section.
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Title block properties section

The title block section from the folio properties is the section used to define the title block template used at the folio.
The folio variables can also be managed from this section.

Note

To reduce the creation time, QElectroTech allows creating some pre-setting for all future folios that will be
created in the project. The folio variable values and the folio title block can be prefedined at the project
properties. For more information about how to pre-define folio properties, refert to project properties section.

The title block section is organized on three different areas: title block selection area, main variable tab and costum
variable tab.

Title block selection area

The title block selection area is used to defne the folio title block. The actions that can be managed from this section
are:

1. Select the folio title block from the project title block collection.

2. Select the position of the title block in the folio, bottom  or right  side.

3. Edit the title block pressing the button  and choosing the option Edit this template.

4. Duplicate the title block in the project title block collection pressing the button  and choosing the option
Duplicate and edit this template.

Figure: Folio title block selection area

Seealso

For more information about QEelctroTech title block, refer to title block section.

Main folio properties tab

The Main tab provides thes default folio variables.

Figure: Folio title block main tab

The default folio variables are:

• Title: Title from the folio.

• Author: Author from the folio.

• Date: Date of creation of the folio.

• File:
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• Folio: Folio information (Label).

• Plant: Folio variable named Plant.

• Location: Folio variable named Location.

• Rev index: Revision index from the folio.

• Page Num: Auto numbering pattern from the folio.

Seealso

For more information about default variables, refer to variables section.

Costum properties folio tab

The Costum tab is the section where custom variables can be defined.

Figure: Folio title block custom tab

To define a user folio variable:

1. Define variable name at the Name column from the variables table.

2. Define variable value at the Value column from the variables table.

Folio conductor type

The Type tab from folio properties PopUP window allows pre-defining the type of conductor that will be drawn in the
folio later. The conductor properties can also be pre-defined. This action avoid defining individually the conductor
type and the common properties for each conductor created in the folio.

Seealso

For more information about conductor properties, refer to conductor type section.

Figure: QElectroTech folio type properties tab
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Seealso

For more information about how to display folio properties, refer to display folio properties section.

Folio conductor appearance

The Appearance tab from folio properties PopUP window allows pre-defining the conductor appearance of the
conductors that will be drawn in the folio later. If all conductors from the folio should have the same appearance, this
action avoid defining individually the conductor appearance.

Seealso

For more information about conductor properties, refer to conductor appearance section.

Figure: Folio appearance properties

Seealso

For more information about how to display folio properties, refer to display folio properties section.

Title Block

What is the title block?

The title block of a drawing is a table which usually is placed at the bottom from the drawing. The title block is the
responsible to provide all necessary information to identify and verify the drawing validity.

Figure: QElectroTech Title block example

Some information which can be found at a title block is:
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• Drawing / Schema title

• Drawing / Schema number

• Drawing / Schema size (Horizontal A3 sheet is the more common at electrical shemas)

• Revision index

• Author

• Date

• License (Ex.: ISO 16016 protection notices for restricting the use of documents and products)

• Logo

Note

Refer to IEC 61082-1 norm for more detailed information about the recomended content that should be included
in the title block.

As table, the elemets from a title block are:

1. Cell

2. Column

3. Row

Title block properties

Title block parent collection

The parent collection property from a title block defines the title block collection to which the title block belongs.

This property defines the rights from the user to edit the title block. A title block with QET title block collection as
parent collection can only be read by the user. A title block with user title block collection or project title block
collection as parent collection can be read and writed (edited) by the user.

The parent collection from a title block can be defined during the save process.

Figure: QElectroTech title block save PopUP window

Title block extra information

QElectroTech provides the option to define a string field property named Extra information. This property field is
provided to allow the user defining the author and/or license from title block. Any other information can also be
defined in this property field.

Figure: QElectroTech title block extra information PopUP window

To display/edit the extra information from the title block:
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1. Display title block in the title block editor.

2. Go to Edit > Edite extra information menu item to display extra information PopUP window.

Figure: QElectroTech title block edit menu

Seealso

For more information about customizing title block extra information, refer to define title block extra information
section.

Title Block collections

What is a collection?

A title block collection is a database where all title block files are storaged and classified.

QElectroTech has two different title block collections integrated, QET collection and User collection. The title block
collections can be found at projects panel.

Figure: QElectroTech projects panel

QElectroTech displays also a third collection when a project is opened, the project collection. This collection is not
part from the software structure and it is managed automatically by QElectroTech during the folio title block definition.

Title block QET collection

The QET collection is the default collection from QElectroTech. This collection is protected and the user can only
read it, the QET collection cannot be edited. The user cannot add or delete any title block in the database.

Figure: QET collection tree at project panel

Title block User collection

The User collection is the QElectroTech collection where the user can create title block, the user is allowed to read
and edit the collection. The allowed actions at the User collection are:
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1. Add new title block.

2. Edit title block from collection.

3. Delete title block from collection.

Figure: Example user collection tree at project panel

Title block project collection

The project collection is the only collection which is not part from the software structure. A project collection is a title
block collection that is part of the project file, each project has its own title block collection.

Figure: QElectroTech project tree

QElectroTech does not allow working on this collection, the user cannot add or delete any title block manually. The
user can only edit title blocks used in the project without modifying the original title block from QET or User collection.

The title block is copied from QET or User collection automatically by QElectroTech when the user introduces a new
title block in one folio of the project. If the title block has already been used previously, QElectroTech does not need
to add again the title block to the project collection.

If one title block is deleted from the project, QElectroTech does not delete the title block from the project collection
automatically, the title block is marked in red. Cleaning the project deletes all title block from the project collection
that are not used inside the project automatically at the cleaning time.

Title block elements

Cell

Definition

A cell from the title block is the most basic storage unit avaliable. The three different type of cells are: empty cell, text
cell and logo cell.
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Empty cell

An empty cell is used when the area occupied by the cell should be empty and without any edge displayed. This type
of cell has no properties.

Figure: QElectroTech title block empty cell properties

Text cell

An text cell is used when the area occupied by the cell should be filled by string information inside a rectangle. This
type of cell has different parameters that can be defined.

Figure: QElectroTech title block text cell properties

Name: Name from cell

Label: When the cell should display a variable from the folio or project properties, the label is the text
that appears before the variable.

Text: It can be a simple string defined by the user or a variable from the folio or project (Ex: Author,
Revision, Date, project name, folio page, etc.).

Font: Font from the label and text of the cell.

Alignment: Vertical and horizontal position of the label and text from the cell inside the cell.

Logo cell

A logo cell is used when the area occupied by the cell should be filled by a picture inside a rectangle. This type of cell
has different parameters that can be defined.

Figure: QElectroTech title block logo cell properties

Name: Name from cell

Logo: Name of the Scalable Vector Graphic (SVG) file with the logo image.

Note

Many different tools allows you to create Scalable Vector Graphics, SVG files. Inside the Open Source world,
Inkscape is on of the recomended tools.

Row

Definition

A row of cells from the title block is a group of cells that are placed one beside the other.
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Figure: QElectroTech title block row

Properties

A row from the title block has only one property, the height of the cells that are part of the row.

To display the row height:

1. Double click on the row head.

Figure: QElectroTech title block row height property

Note

QElectroTech works with pixels, the height of the row can only be defined according pixel unit.

Column

Definition

A column of cells from the title block is a group of cells that are placed one over the other.

Properties

At QElectroTech, a column from the title block has only one property, the width of the cells that are part of the
columns.

To display the column width:

1. Double click on the column head.

Figure: QElectroTech title block column width property

QElectroTech works with pixels, the width is defined according pixel unit.

Unlike rows, the width of a column can be defined as:

• Absolut value, pixel units.

• Relative value to total, percent of the total width of the title block.

• Relative value to remaining, percent of the remaining width of the title block.

Create new title block

Creating new title block from cero is not allowed, one template can only be created starting from an other. If no
template is choosed, the default title block from QET collection is the base to create a new title block.
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Figure: QElectroTech default title block

Create title block from menu bar

1. Select Project > Project properties > New folio menu item to display default folio properties from project.

2. Go to title block informations and select the base title block that should be used to create the new one.

3. Select the option Duplicate and edit this template.

Figure: QElectroTech New folio properties PopUP window

4. Choose the name for the new title block template and press OK to create it.

Figure: QElectroTech New folio save PopUP window

Create title block from folio properties

1. Display folio properties from one of the folios of the project.

2. Go to title block informations and select the base title block that should be used to create the new one.

3. Select the option Duplicate and edit this template.
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Figure: QElectroTech New folio properties PopUP window

4. Edit the template and save it.

5. Choose the parent collection and the name from the new title block template, then press OK to create it.

Figure: QElectroTech New folio save PopUP window

Create title block from project panel

1. Right click on the user title blocks collection from project panel.

2. Click the option New template to add a new title block with the default template from QET collection as
base.

Figure: QElectroTech Project panel

Note

If the project panel is not displayed, it can be displayed from Settings > Display > Projects.

Edit title block

QElectroTech only allows editing the templates from User collection or project embedded collection. The QET
collection title blocks cannot be edited.

Note

QElectroTech allows opening the title block templates from QET collection with title block editor. Once the
template is modified, it has to be saved using the option Save as and create a new template.
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Edit title block from menu bar

1. Select Project > Project properties > New folio menu item to display default folio properties from project.

2. Go to title block informations and select the title block which should be edited.

3. Select the option Edit this template to display title block editor.

Figure: QElectroTech new folio properties PopUP window

Edit title block from folio properties

1. Display folio properties from one of the folios of the project.

2. Go to title block informations and select the title block which should be edited.

3. Select the option Edit this template to display title block editor.

Figure: QElectroTech folio properties PopUP window

Edit title block from project panel

1. Right click on one title block template which should be edited.
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2. Click the option Edit this template to open the template with title block editor.

Figure: QElectroTech Project panel

Note

If the project panel is not displayed, it can be displayed from Settings > Display > Projects.

Delete title block

The title blocks templates can only be deleted from project panel. QElectroTech does not allow deleting templates
from any menu item.

Note

If the project panel is not displayed, it can be displayed from Settings > Display > Projects.

It is important to make difference between the project embedded collection and QET or User collection. The project
embedded collection is in the project “database”, delete information from the project does not change anything at
QElectroTech or in the computer file system. Deleting information from QET or User collection deletes information
from QElectroTech “database” and in the computer file system, the information deleted in these “databases” can
never be recovered.

Delete title block from project

1. Right click on one title block template from project embedded collection which should be deleted.

2. Click the option Delete this template to delete the template form project “database”.

Figure: QElectroTech Project panel

Delete title block from collection

1. Right click on the title block template from QET or User collections which should be deleted.

2. Click the option Delete this template to delete the template form QElectroTech and from the file system.

Figure: QElectroTech Project panel
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3. Press YES to confirm the action.

Figure: QElectroTech delete title block confirmation PopUP window

Warning

The template deleted from one collection cannot be recovered, it will be deleted from QElectroTech “dataabse”
and from the computer file system. Be sure about the operation.

Title block editor

Interface title block editor

Elements title block window

The title block editor window is a PopUP window from QElectroTech. It has also been designed using Qt framework
and widget toolkit. The window from QElectroTech title block editor is the same for all platforms where it is available
(Windows, Linux/Unix and MacOS). The window from the title block editor contains the following areas:

1. Menu bar

2. Toolbar

3. Drawing area

4. Panels

Figure: QElectroTech Title block editor window

Title block editor menu bar

The menu bar is placed at top from title block editor window. The title block editor contains the menus File, Edit,
Display, Settings, and Help. Each menu provides many diferent options.

File menu
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Figure: QElectroTech file menu

Option Function
Keyboard
shortcut Icon

New Creates a new Title Block Ctrl + n

Open Opens an existing Title Block from collection Ctrl + o

Open from a file Opens an existing Title Block from file Ctrl + o

Save Saves the current Title Block changes (overwrites) Ctrl + s

Save as Saves the Title Block as a new Title Block from a
library

Save to a file Saves the Title Block as a different file in disk Ctrl + Shif
t + x

Quit Quits QElectroTech Title Block editor Ctrl + q

Edit menu

Figure: QElectroTech edit menu

Option Function
Keyboard
shortcut Icon

Undo Undoes the previous action Ctrl + z

Redo Restores the undone action Ctrl + shift
 + z

Cut Puts selected elements / cells into the
clipboard

Ctrl + x

Copy Copies selected elements / cells Ctrl + c

Paste Pastes elements from the clipboard into
cell

Ctrl + v

Add a row Adds a row at bottom from title block

Add a column Adds column at right side from title block

Merge cells Merges selected cells Ctrl + j

Split cells Splits selected cells Ctrl + k

Manage logos Manages pictures to embed logos in the
title block

Ctrl + t

Edit extra information Displays field to specify aditional
information

Ctrl + y

Display menu
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Figure: QElectroTech display menu

Option Function
Keyboard
shortcut Icon

Zoom In Expands the workspace Ctrl + +

Zoom Out Shrinks the workspace Ctrl + -

Fit in view Adjusts the zoom on exactly trhe part of the workspace Ctrl + 9

Reset zoom Restores default zoom level Ctrl + 0

Settings menu

Figure: QElectroTech settings menu

Option Function Keyboard shortcut Icon

Display Displays or hides toolbars and panels

Full screen mode Displays QElectroTech in full screen mode Ctrl + Shift + f

Configure
QElectroTech

Allows specifying various parameters for
QElectroTech

Help menu

Figure: QElectroTech help menu

Option Function
Keyboard
shortcut Icon

What’s This? Enquires main menu options Shift + f1

About QElectroTech Displays information about QElectroTech

Online manual Lauches the default browser to the online manual of
QElectroTech

f1

Youtube channel Lauches the default browser on the Youtube channel of
QElectroTech

Support the project
with a donation

Lauches the default browser on the QElectroTech
donation paypal account

About Qt Displays information about Qt library

Toolbars

In addition to the different menus, QElectroTech provides also toolbars. The toolbars are groups of buttons with
icons which initiate an accion. In general, these buttons have its counterpart at one of the menus from the menu bar.

The different toolbars can be hidden or placed in one or more rows below the menu bar. The toolbars can also be
placed on column at the left or right side from the main window.
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Note

To help the user, a tooltip is displayed when the arrow is placed on each button.

Toolbar Tools

Figure: QElectroTech title block toolbar Tools

The different buttons from toolbar Tools are:

Option Function
Keyboard
shortcut Icon

New Creates a new Title Block Ctrl + n

Open Opens an existing Title Block from collection Ctrl + o

Save Saves the current Title Block changes (overwrites) Ctrl + s

Save as Saves the Title Block as a new Title Block from a
library

Note

Select Settings > display > Tools menu item to display or hidden the toolbar Tools.

Toolbar Edit

Figure: QElectroTech title block toolbar Element

The different buttons from toolbar Edit are:

Option Function
Keyboard
shortcut Icon

Undo Undoes the previous action Ctrl + z

Redo Restores the undone action Ctrl + shift
 + z

Merge cells Merges selected cells Ctrl + j

Split cells Splits selected cells Ctrl + k

Note

Select Settings > display > Edit menu item to display or hidden the toolbar Edit.

Toolbar Display

Figure: QElectroTech title block toolbar Display

The different buttons from toolbar Display are:
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Tool Function
Keyboard
shortcut Icon

Zoom in Zoom in at drawing area Ctrl + +

Zoom
out

Zoom out at drawing area Ctrl + -

Fit in
view

Adjusts the zoom on exactly the part of the workspace Ctrl + 9

Reset
zoom

Restores default zoom level Ctrl + 0

Note

Select Settings > display > Display menu item to display or hidden the toolbar Display.

Drawing area

The drawing area or grafical editor, is the area where the title block columns, rows and cells are managed.

How looks the drawing area from title block editor is shown below.

Figure: QElectroTech title block grafical editor

Title block editor panels

Cell properties panel

The Cell properties panel displays the properties from the selected cell.

Figure: QElectroTech Cell properties panel

To display the Cell properties panel:

1. Select Settings > display > Cell properties menu item to display Cell properties panel.

Undo panel

The Undo panel displays the history since last time that the title block was saved. Once the title block is saved, undo
panel is automatically cleaned.

Figure: QElectroTech Undo panel

To display Undo panel:

1. Select Settings > display > Undo menu item to display Undo panel.
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Seealso

For more information about utilities from Undo panel, refer to QElectroTech Undo panel section.

Open title block editor

QElectroTech allows displaying the title block editor by one of the following actions:

• Create new title block

• Edit title block

Save title block

The current title block can be saved from menu bar, toolbar and using the corresponding keyboard shortcut.

One title block is conformed by only one file with the format .titleblock. The .titleblock extension is the
native extension from QElectroTech title blocks.

Save title block from menu bar

1. Select File > Save menu item to save the title block changes.

Figure: QElectroTech title block editor File menu

At the case that the opened title block has to overwrite an existing title block or it has to be saved as new title block:

1. Select File > Save as menu item to display Save as title block PopUP window.

Figure: QElectroTech Save as title block PopUP window

2. Select the title block which should be overwritten or the parent collection and the name for the new title
block.

3. Press OK button to save the title block and close the PopUP window.

The title block can also be directly saved as a new file in the Hard Disk directory desired:

1. Select File > Save to a file menu item to display the File system PopUp window.

2. Select the directory and the name from the title block file.

3. Press OK button to save the title block and close the PopUP window.

Save title block from toolbar

1. Select icon  from toolbar to save title block changes.

At the case that the opened title block has to overwrite an existing title block or it has to be saved as new title block:

1. Select icon  from toolbar to display the Save as title block PopUP window.
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Figure: QElectroTech Save as title block PopUP window

2. Select the title block which should be overwrited or the parent collection and the name for the new title
block.

3. Press OK button to save the title block and close the PopUP window.

Note

If the toolbar is not displayed, it can be displaed from Settings > Display > Tools.

Save title block using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + s to save the title block changes.

The title block can also be directly saved as a new file in the Hard Disk directory desired:

1. Press Ctrl + Shift + s to display the File system PopUp window.

2. Select the directory and the name from the title block file.

3. Press OK button to save the title block and close the PopUP window.

Seealso

For more information about QElectroTech keyboard shortcut, refer to Menu bar section.

Quit title block editor

The title block editor can be closed at any time, only the changes have to be saved before closing it. QElectroTech
displays an automatic message to save the current job if any modification has been created.

Figure: QElectroTech title block editor save message

Exit QElectroTech title block editor from menu bar

1. Select File > Quit menu item to quit QElectroTech title block editor.

Figure: QElectroTech title block editor File menu

Exit QElectroTech title block editor using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + q to quit QElectroTech title block editor.
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Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Create or edit title block

Add row to title block

QElectroTech title block editor allows adding row from menu bar and drawing area.

Add row from menu bar

1. Select Edit > Add a row menu item to add a new row below.

Figure: QElectroTech title block editor, edit menu

Note

Adding a new row at top or middle from title block can only be done from drawing area.

Add row from drawing area

1. Right click on the head from the row below or above the position where the new row should be placed.

2. Click the option Add a row (before) or Add a row (after) to add a new row above or below the selected
row.

Figure: QElectroTech title block editor, drawing area

Row heigth definition

The heigth from a row can only be defined from row head, the left cell which is given the heigth value from the
corresponding row . The head from the row is not displayed at folio, it is only displayed at title block editor.

Figure: QElectroTech Title block

1. Double click on row head to display the row heigth PopUp window.
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Figure: QElectroTech Title block row heigth PopUP window

2. Define the heigth value in pixels.
3. Press OK.

Delete row from title block

QElectroTech title block editor only allows deleting rows of the title block from drawing area.

1. Right click on the head from the row which should be deleted.

2. Click the option Delete this row to delete the selected row.

Figure: QElectroTech title block editor, drawing area

Add column to title block

QElectroTech title block editor allows adding columns from menu bar and drawing area.

Add column from menu bar

1. Select Edit > Add a column menu item to add a new column at the right side from the title block.

Figure: QElectroTech title block editor, edit menu

Note

Adding a new column at the middle from the title block can only be done from drawing area.

Add column from drawing area

1. Right click on the head from the column next to the position where the new column should be placed.

2. Click the option Add a column (before) or Add a column (after) to add a new colum before or after the
selected column.

Figure: QElectroTech title block editor, drawing area
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Colum width definition

The width from a column can only be defined from the column head, the top cell from the drawing area which gives
the width value from the corresponding column. The head from the columns is not displayed in the folio, it is only
displayed at title block editor.

1. Double click on column head to display the column width PopUp window.

Figure: QElectroTech Title block column width PopUP window

2. Select the click button corresponding to the desired units to define the column width (Absolute, relative to
total, relative to remainding).

3. Define the width value.

4. Press OK.

Note

The global width from the title block has to be defined at QElectroTech, for this reason, defining one column width
as remanding of 100% is recomended.

Figure: QElectroTech Title block

At the case that a remanding width is not desired, be sure that the global width from the title block matches with
the sum of all column widths. At the case that the values are not matching, QElectroTech will display the title
block as shown below; part of the title block header will be displayed in red and the width difference will be
displayed.

Figure: QElectroTech Title block global width error

Warning

At the case of using Relative to remainding, be sure that the value from the width is 100 %. Otherwise, spare
area will appear in the title block.

Figure: QElectroTech Title block column width error
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Delete column from title block

QElectroTech title block editor only allows deleting columns from drawing area.

1. Right click on the head from the column which should be deleted

2. Click the option Delete this column to delete the selected column.

Figure: QElectroTech title block editor, drawing area

Introduce a logo on the title block

1. Select the cell where the logo should be introduced.

2. Go to properties and choose Logo at Cell type Combo Box.

Figure: QElectroTech Title block cell properties

3. Define the name of the cell, if it is desired.

4. Press the Manage logo button to display the logo manager PopUP window.

Figure: QElectroTech Title block logo manager PopUP window

5. Press the button Add a logo to display the file explorer PopUP window.

6. Choose the SVG or Bitmap file with the desired logo and close the logo manager.

7. Choose the logo added previously at Logo Combo Box.

Define cell content

QElectroTech title block editor allows defining two differen types of content in a text cell type:

• Plain text

• Variable

QElectroTech works managing different database, the content of the cells are storage in the project database.
QElectroTech provides the feature of defining the cell content in different languages, the cell content is defined in a
cell value table. The content from the different cells of the title block are automatically displayed in the language
defined.
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Note

The working language from QElectroTech is defined at Setting > Configure QElectroTech.

Add text to cell

1. Select the cell where the text should be introduced.

2. Press Edit button from text field and the cell value PopUP window will be displayed.

3. Press the button Add a line to add a new row in the cell value table.

4. Define the 2 letter code that identifies the language from the text at Language column.

5. Define the text at Text column.

6. Press OK

Note

QElectroTech works according ISO 639-1 norm. The text language is defined using 2 letter code which should be
used at the language column from the cell value table.

Figure: QElectroTech title block editor, cell label PopUP window

Add variable to cell

A title block variable is the value of a project or folio property. At QElectroTech, a variable is called using the percent
symbol before the variable name (%{variable-name}).

Note

QElectroTech has some default variables that the user does not need to create (ex.: %{author}, %{date},
%{title}, %{folio}, %{projecttitle}, etc.).

QElectroTech also allows the user defining extra variables:

• Go to Project > Project properties > General to define costumized project variables.

• Go to Edit > Folio properties > Title block informations > Costum to define costumized folio
variables.

QElectroTech allows that the cell has a Label for the variable.

To define the label:

1. Select the cell where the variable should be introduced.

2. Click the button Display a label to introduce a label in the cell. Click on the button and go to variable
definition if the Label should not be displayed.
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Figure: QElectroTech Title block text cell properties

3. Press Edit button from label field and the label value PopUP window will be displayed.

Figure: QElectroTech title block editor, cell value PopUP window

4. Press the button Add a line to add a new row in the Label value table.

5. Define the 2 letter code that identifies the language from the text at Language column.

6. Define the text at Text column.

7. Press OK

To define the variable:

8. Press Edit button from text field and the cell value PopUP window will be displayed.

9. Press the button Add a line to add a new row in the cell value table.

10. Define the 2 letter code that identifies the language from the text at Language column. Defining only one
languaje is enough for default variables.

11. Define the variable at Text column. A variable is defined as %{variable-name}. The default variables
can be copied to clipboard at the right bottom Combo Box and pasted (Ctrl + c) in Text column cell.

Figure: QElectroTech title block editor, cell value PopUP window

12. Press OK

Seealso

For more information about default variables, refer to default QElectroTech variables section.

Merge cells

QElectroTech title block editor allows merging cells from menu bar, toolbar and using the corresponding keyboard
shortcut.

QElectroTech has no restrictions merging cells, QElectroTech allows merging cells from same column and/or row.

Merge cells from menu bar
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1. Select the cells which should be merged.

2. Select Edit > Merge cells menu item to merge the selected cells.

Figure: QElectroTech title block editor, edit menu

Note

To select more than one cell, press Ctrl from keyboard.

Merge cells from toolbar

1. Select the cells which should be merged.

2. Select the icon  from toolbar to merge the selected cells.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Edit

Merge cells using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the cells which should be merged.

2. Press Ctrl + j to merge the selected cells.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Split cells

QElectroTech title block editor allows splitting cells previously merged from menu bar, toolbar and using the
corresponding keyboard shortcut.

Split cells from menu bar

1. Select the merged cells which should be splitted.

2. Select Edit > Split cells menu item to split the selected cells.
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Figure: QElectroTech title block editor, edit menu

Split cells from toolbar

1. Select the merged cells which should be splitted.

2. Select the icon  from the toolbar to split the selected cells.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Edit

Split cells using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the merged cells which should be splitted.

2. Press Ctrl + k to split the selected cells.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Define title block extra information

Define extra information from menu bar

1. Select Edit > Edit extra information menu item to display extra information PopUp window.

Figure: QElectroTech title block editor Edit Menu

2. Introduce the desired information in the text field.

3. Press OK to accept and close extra information PopUp window.

Define extra information using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + y to display the extra information PopUp window.

2. Introduce the desired information in the text field.

3. Press OK to accept and close extra information PopUp window.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.
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Element

What is an element?
An element is an object wich contains information:

1. Graphical representation information, symbol displayed at the schema.

2. Element data such element position in the poject, article number, manufacturer, supplier, link to any other
element from the project, etc.

Figure: QElectroTech thermal circuit breaker element

An element is an object which function is to reduce the engineering work. Working with elements reduce the time and
work necessary for the creation of schemas, Bill Of Materials (BOM) and many other types of reports such terminal
lists, I/O lists, etc.

The element can be clasified at different families:

• Simple

• Master

• Slave

• Reference folio following

• Previous reference folio

• Terminal block

The graphical representation information characteristics are the same for all families. The element data properties
fields and the possible interloking options are diferent between families.

Type of elements

Simple element

The simple element is used to represent devices such actuators (electric motors, cylinders, pneumatic or hydraulic
valves, etc.), control devices (PLC, microcontrollers, etc.), circuit breakers, etc.
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Figure: QElectroTech simple element

For simple element exist two type of variables:

1. General variables common for all type of elements and managed internally by QElectroTech.

2. Specific variables from simple elements.

General variables

• % {F}: Label from the folio where the element can be found

• % {f}: Number from the folio where the element can be found

• % {M}: Plant variable from the folio where the element can be found

• % {LM}: Location variable of the folio where the element can be found

• % {l}: Folio line number from the workspace where the element can be found

• % {c}: Folio column number from the workspace where the element can be found

• % {id}: Folio position in the project (Schema number)

Specific variables

• Label formula: Definition of the formula which defines the Label value. If a auto numbering pattern is
selected during terminal creation, QElectroTech defiens %autnum as default formula.

• Label: Internal variable which is used to defines the element code.

• Annotation: Internal variable, it cannot be a formula (group of other variables).

• Textual description: Internal variable, it cannot be a formula (group of other variables).

• Article number: Internal variable, it cannot be a formula (group of other variables).

• Manufacturer: Internal variable, it cannot be a formula (group of other variables).

• Order number: Internal variable, it cannot be a formula (group of other variables).

• Supplier: Internal variable, it cannot be a formula (group of other variables).

• Auxiliry block 1: Internal variable, it cannot be a formula (group of other variables).

• Auxiliry block 2: Internal variable, it cannot be a formula (group of other variables).

• Internal number: Internal variable, it cannot be a formula (group of other variables).

• Location: Internal variable, it cannot be a formula (group of other variables).

• Function: Internal variable, it cannot be a formula (group of other variables).

• Voltage/Protocol: Internal variable, it cannot be a formula (group of other variables).
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Master element

The master elements represent the devices from the command circuit such the coil from a relay or contactor.

Figure: QElectroTech master element

For master element exist two type of variables, the general variables that are common for all type of elements and
managed internally by QElectroTech, and the specific variables for this type of element.

QElectroTech allows defining variable values from master element at the Selection properties panel. QElectroTech
does not allow defining new variables. QElectroTech allows only displaying variables at dynamic texts and define
value of the specific variables.

Note

If the Selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties.

General variables

• % {F}: Label from the folio where the element can be found

• % {f}: Number from the folio where the element can be found

• % {M}: Plant variable from the folio where the element can be found

• % {LM}: Location variable of the folio where the element can be found

• % {l}: Folio line number from the workspace where the element can be found

• % {c}: Folio column number from the workspace where the element can be found

• % {id}: Folio position in the project (Schema number)

Specific variables

• Label formula: Definition of the formula which defines the Label value. If a auto numbering pattern is
selected during terminal creation, QElectroTech defiens %autnum as default formula.

• Label: Internal variable which is used to defines the element code.

• Annotation: Internal variable, it cannot be a formula (group of other variables).

• Textual description: Internal variable, it cannot be a formula (group of other variables).

• Article number: Internal variable which, it cannot be a formula (group of other variables).

• Manufacturer: Internal variable, it cannot be a formula (group of other variables).

• Order number: Internal variable, it cannot be a formula (group of other variables).

• Supplier: Internal variable, it cannot be a formula (group of other variables).
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• Auxiliry block 1: Internal variable, it cannot be a formula (group of other variables).

• Auxiliry block 2: Internal variable, it cannot be a formula (group of other variables).

• Internal number: Internal variable, it cannot be a formula (group of other variables).

• Location: Internal variable, it cannot be a formula (group of other variables).

• Function: Internal variable, it cannot be a formula (group of other variables).

• Voltage/Protocol: Internal variable, it cannot be a formula (group of other variables).

Slave element

The slave elements represent the power circuit devices such the main contactors from power contactors. The slave
elements also represent the auxiliary contactors. Even if an auxiliary contactor is part of the command circuit, its
activation is forced by another element.

Figure: QElectroTech slave element

For slave element exist two type of variables, the general variables that are common for all type of elements and
managed internally by QElectroTech, and the specific variables for this type of element.

QElectroTech does not allow defining variable values for slave element. QElectroTech does also not allows defining
new variables. QElectroTech allows only displaying the specific variables at dynamic texts.

General variables

• % {F}: Label from the folio where the element can be found

• % {f}: Number from the folio where the element can be found

• % {M}: Plant variable from the folio where the element can be found

• % {LM}: Location variable of the folio where the element can be found

• % {l}: Folio line number from the workspace where the element can be found

• % {c}: Folio column number from the workspace where the element can be found

• % {id}: Folio position in the project (Schema number)

Specific variables

• Position master element: Internal pre-defined variable which is automatically displayed under dinamic
texts of the element. The default formula from the variable is (%id-%l%c), variables took from master
element.

Seealso

The default formula from the Position master element and the position where it should be displayed can be
defined at cross references tab from New project preferences.
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Note

QElectroTech allows also displaying the specific variables from the Master element at the dynamic text fields.

Reference folio following

Element which link the end of a conductor with the begining of the conductor represented at previous, following or
the same folio.

Figure: QElectroTech reference folio following

For reference folio following element exist two type of variables, the general variables that are common for all type of
elements and the specific variables for this type of element.

QElectroTech does not allow defining variable values for this type of element. QElectroTech does also not allows
defining new variables. QElectroTech allows only displaying the specific variables at dynamic texts.

General variables

• % {F}: Label from the folio where the element can be found.

• % {f}: Number from the folio where the element can be found.

• % {M}: Plant variable from the folio where the element can be found.

• % {LM}: Location variable of the folio where the element can be found.

• % {l}: Folio line number from the workspace where the element can be found.

• % {c}: Folio column number from the workspace where the element can be found.

• % {id}: Folio position in the project (Schema number).

Specific variables

• Function: Function property from the conductor connected to the element terminal.

• Label: Internal variable which defines the position of the linked previous reference folio element.

• Voltage/Protocol: Voltage/Protocol property from the conductor connected to the element terminal.
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Note

The Label property can be defined as a formula by the user at New folio section from project properties. By
default the formula is %id-%l%c, variables took from previous reference folio linked element.

For more information about how to define the Label formula, please refers to folio referencing project properties.

Previous reference folio

Element which link the begining of a conductor with the end of the conductor represented at previous, following or
same folio.

Figure: QElectroTech previous reference folio

For previous referencing folio element exist two type of variables, the general variables that are common for all type
of elements and the specific variables for this type of element.

QElectroTech does not allow defining variable values for this type of element. QElectroTech does also not allows
defining new variables. QElectroTech allows only displaying the specific variables at dynamic texts.

General variables

• % {F}: Label from the folio where the element can be found.

• % {f}: Number from the folio where the element can be found.

• % {M}: Plant variable from the folio where the element can be found.

• % {LM}: Location variable of the folio where the element can be found.

• % {l}: Folio line number from the workspace where the element can be found.

• % {c}: Folio column number from the workspace where the element can be found.

• % {id}: Folio position in the project (Schema number).

Specific variables

• Function: Function property from the conductor connected to the element terminal.

• Label: Internal variable which defines the position of the linked reference folio following element.

• Voltage/Protocol: Voltage/Protocol property from the conductor connected to the element terminal.
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Note

The Label property can be defined as a formula by the user at New folio section from project properties. By
default the formula is %id-%l%c, variables took from reference folio following linked element.

For more information about how to define the Label formula, please refers to folio referencing project properties.

Terminal block

Element which represents a terminal block, connection between two cables from the same potential.

Figure: QElectroTech Terminal block

For terminal block element exist two type of variables, the general variables that are common for all type of elements
and managed internally by QElectroTech, and the specific variables for this type of element.

QElectroTech allows defining variable values from this type of element at the Selection properties panel.
QElectroTech does not allow defining new variables. QElectroTech allows only displaying variables at dynamic texts
and define value of the specific variables.

Note

If the Selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties.

General variables

• % {F}: Label from the folio where the element can be found

• % {f}: Number from the folio where the element can be found

• % {M}: Plant variable from the folio where the element can be found

• % {LM}: Location variable of the folio where the element can be found

• % {l}: Folio line number from the workspace where the element can be found

• % {c}: Folio column number from the workspace where the element can be found

• % {id}: Folio position in the project (Schema number)

Specific variables

• Label formula: Definition of the formula which defines the Label value. If a auto numbering pattern is
selected during terminal creation, QElectroTech defiens %autnum as default formula.

• Label: Internal variable which is used to defines the element code.

• Annotation: Internal variable, it cannot be a formula (group of other variables).

• Textual description: Internal variable, it cannot be a formula (group of other variables).

• Article number: Internal variable, it cannot be a formula (group of other variables).

• Manufacturer: Internal variable, it cannot be a formula (group of other variables).
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• Order number: Internal variable, it cannot be a formula (group of other variables).

• Supplier: Internal variable, it cannot be a formula (group of other variables).

• Auxiliry block 1: Internal variable, it cannot be a formula (group of other variables).

• Auxiliry block 2: Internal variable, it cannot be a formula (group of other variables).

• Internal number: Internal variable, it cannot be a formula (group of other variables).

• Location: Internal variable, it cannot be a formula (group of other variables).

• Function: Internal variable, it cannot be a formula (group of other variables).

• Voltage/Protocol: Internal variable, it cannot be a formula (group of other variables).

Element properties

Display element properties

The element properties can be displayed at the selection properties panel or in a popUP window. At the case of
working without selection properties panel, the properties can be displayed from menu bar, workspace or using
keyboard shortcut.

Note

At the case of using the selection properties panel, selecting the element is enough to display automatically the
element properties at the panel.

If the Selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties.

Display element properties from menu bar

1. Select the element which properties should be displayed.

2. Select Edit > Edit this element menu item to display the element properties PopUP window.

Figure: QElectroTech Edit menu

Display element properties from workspace

1. Right click on the element which properties should be displayed.

2. Select Edit this element option to display the element properties PopUP window.
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Figure: QElectroTech element options

Display element properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the element which properties should be displayed.

2. Press Ctrl + e to display the element properties PopUP window.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

General properties element

The general properties section from an element provides the information:

• Element name

• Element position in the project (folio, coordenates, rotation, etc.)

• Element size

• Number of terminals that the element has

• Directory where the element file can be found

Figure: QElectroTech general element properties

Texts from element

The element texts section provides all text properties from the text field and dynamic text integrated in the element.
The text properties available are:
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• Text

• Source of the text

• Size

• Font

• Color

• Frame

• Width

• Position

• Rotation

• Alignment

Figure: QElectroTech text element properties

Element information

The element information section provides all information from the element which can be exported to the Bill of
Materials (BOM). At this section the avaliable information is:

• Element label

• Element location in the system

• Element article number

• Element manufacturer

• Element supplier

• Etc.

Note

The element information section is only available for simple, master or terminal block elements.

Figure: QElectroTech information element properties
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Element author and license

QElectroTech provides the option to define the author and the desired license from the element.

Figure: QElectroTech author and license element PopUP window

The author and the license from an element cannot be displayed at the main window from QElectroTech, this
information can only be found from element editor.

Seealso

For more information about how to find the license and author from an element, refer to define author element
information section.

Element numbering

QElectroTech allows an automatic codification of elements. This feature is useful for the creation of reports, Bill of
Materials (BOM), and for the identification of devices at the physical installation and schemas.

QElectroTech allows defining multiples auto numbering patterns. It also provides many flexibility on the creation of
auto numbering pattern using text, variables and sequential numbers.

Figure: QElectroTech element auto numbering

Example

X AAAA
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X: Code defined by IEC 81346 norm.

• A: Two or more purposes or tasks.

• B: Converting an input variable into a signal for further processing.

• C: Storing of energy, information or material.

• E: Providing radiant or thermal energy.

• F: Direct protection from dangerous or unwanted conditions.

• G: Initiating a flow of energy or material.

• H: Producing a new kind of material or product.

• K: Processing signals or information.

• M: Providing mechanical energy for driving purposes.

• P: Presenting information.

• Q: Controlled switching or varying a flow of energy, of signals or of material.

• R: Restricting or stabilizing motion or a flow of energy or material.

• S: Converting a manual operation into a signal for further processing.

• T: Conversion of energy maintaining the kind of energy.

• U: Keeping objects in a defined position.

• V: Processing (treating) of material or products.

• W: Guiding or transporting from one place to another.

• X: Connecting objects
AAAA: Alphanumeric code which identify the element.

Seealso

For more information about how to define auto numbering patterns, refer to project auto numbering properties
section.

For more information about how to manage the codification of conductors, refer to add element section.

Element collection

What is a collection?

An element collection is a database where all element files are storaged and classified. The element collection gives
the information about the element name, category (folder); sub-categories (sub-folders) and category or
sub-category path in the file system.

QElectroTech has two different element collections integrated, QET collection and User collection.
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Figure: Collection panel

QElectroTech displays also a third collection in the collections panel when a project is opened, the project collection.
This collection is not part from the software structure and it is treated automatically by QElectroTech during the draw
proces in the workspace.

QET collection

The QET collection is the default collection from QElectroTech. This collection is protected and the user can only
read it, the QET collection cannot be edited. The user cannot add any element, any category or sub-category and
cannot re-organize the elements in the database.

Figure: QET collection tree at collection panel

The QET collection has the following categories:

Electric: Collection of electrical components (motors, converters, switches, electrical protections, etc.)

Logic: Logic signal symbols (AND, OR, NOT, NOR, etc.), Grafcet symbols, Ladder symbols and flow
char symbols.

Hydraulic: Collection of hydraulic components (Pumps, cylinders, pressure limit valves, pressure relief
valves, directional valves, etc.)

Pneumatic: Collection of hydrualic components (Compressor, cylinders, air filters, directional valves, etc.)

Energy: Collection of elements used at the energy field (pumps, turbines, solar panels, heat
exchangers, etc.)

User collection

The User collection is the QElectroTech collection where the user can create and organize elements, the user is
allowed to read and edit the collection. The actions allowed at the user collection are:

1. Add new elements.

2. Edit elements from the collection.

3. Delete elements from the collection.

4. Create new categories / folders.

5. Create new sub-categories / sub-folders.

6. Delete categories or sub-categories.

7. Re-organize the collection.

Figure: Example user collection tree at collection panel
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Project collection

The project collection is the only collection which is not part from the software structure. A project collection is an
element collection that is part of the project file, each project has its own element collection.

Figure: QElectroTech project collection

QElectroTech does not allow working in this collection, the user cannot add or delete any element, category or
sub-category manually. The user can only read the category or sub-category properties and use the collection to
access to the elements of the project to edit them.

The elements are copied from QET or User collection by QElectroTech automatically when the user introduces a
new element at one folio of the project. If the element has already been used previously, QElectroTech does not add
the element to the project collection again.

If one element is deleted from the project, QElectroTech does not delete the element from the project collection
automatically, the element is remarked in red. Cleaning the project deletes all elements from the project collection
that are not used inside the project and reduces the size of the project file.

Create category

Working with collections can only be done from collections panel.

Note

Select Settings > Display > Collections menu item to display the collections panel.

QElectroTech allows creating categories at some collection. The user has only read rights at QET collection, the user
can create categories at User collection.

1. Right click on User collection or at a category / sub-category from the User collection.

Figure: Options at folder

2. Click the option New folder to open Add a new category PopUP window.
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Figure: New category PopUP window

3. Define the internal name for the file system.

4. Define the category name that will be displayed at the collection tree, it can be defined in many languages.

5. Press OK to add the new category / sub-category.

Note

QElectroTech works according ISO 639-1 norm. The folder name language is defined using 2 letter code which
should be used at the language column from the folder internal name table.

Edit category

Working with collections can only be done from collections panel.

Note

Select Settings > Display > Collections menu item to display the collections panel.

1. Right click on the user collection or at a category from the collection which should be edited.

Figure: Options at folder

2. Click the option Edit folder to open Add a new category PopUP window.

Figure: New category PopUP window

3. Edit the category name or add a new translation from the category name pressing Add a line.

4. Press OK to change the category properties.

Note

QElectroTech works according ISO 639-1 norm. The folder name languaje is defined using 2 letter code which
should be used at the languaje column from the folder internal name table.
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Delete category

Working with collections can only be done from collections panel.

Note

Select Settings > Display > Collections menu item to display the collections panel.

QElectroTech allows deleting categories from some collection. The user has only read rights at QET element
collection, the user can delete categories from all collections except QET collection.

1. Right click on the category / sub-category from the collection that should be deleted.

Figure: Options at folder

2. Click the option Delete folder to delete the category / sub-category.

3. A PopUP confirmation window will be displayed, press OK to confirm and delete the category / sub-category.

Figure: Deleting PopUP window confirmation

Warning

Be sure about what should be deleted, the category / sub-category and all elements will be deleted from the
collection and file system.

Folder properties

At QElectroTech folder and category are the same. The properties from a folder are:

• Number of elements in the folder.

• Number of sub-folders (sub-categories) in the folder.

• Internal QElectroTech collection path from the folder.

• File system path from the folder.

Working with collections can only be done from collections panel.

Note

Select Settings > Display > Collections menu item to display the collections panel.

1. Right click on the category (folder) from the collection whose properties should be displayed.
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Figure: Options at folder

2. Click the option Folder properties to display the PopUP window which shows the folder properties.

Figure: Folder properties PopUP window

Create element

Working with collections can only be done from the collections panel. Before starting to work with collections, the
collections panel has to be displayed.

Note

Select Settings > Display > Collections menu item to display the Collections panel.

QElectroTech allows creating element at some collection. The user has only read rights at QET element collection,
the user can create element at all collections except QET collection.

There is two different ways to create a new eleemnt at the user collection. A new element can be created from cero
or from an already existing element from the QET or user collection.

Create element from cero

1. Right click on the user collection or at the category / sub-category from the collection where the new element
should be added.

Figure: Options at folder

2. Click the option New element to start the element creation.

3. Confirm or change the category from the element.
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4. Define the element file name.

Figure: File name definition PopUP window

5. Define the element name for the collection and project tree. It can be defined in many languajes.

Figure: Element name definition PopUP window

Note

QElectroTech works according ISO 639-1 norm. The element name languaje is defined using 2 letter code which
should be used at the languaje column from the folder internal name table.

6. Once the element editor PopUP window is opened, design the symbol element and define the properties.

7. Save the element and it will appear at the collection.

Seealso

For more information about the element editor, refer to Element editor section.

Create an element from an existing element

1. Right click on the element which will be used as base for the new element.

Figure: Options at element

2. Click the option Edit element to open the element at the element editor.

3. Select File > Save as menu item to open the save window.
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4. Choose the element category at the collection tree.

5. Define the file name for the element.

6. Press the button Save.

Edit element

Working with collections can only be done from the collections panel. Before starting to work with collections, the
collections panel has to be displayed.

Note

Select Settings > Display > Collections menu item to display the Collections panel.

QElectroTech allows editing existing element from some collection. The user has only read rights at QET element
collection, the user can edite already existing element from all collections except QET collection element.

1. Right click on the element which should be edited.

Figure: Options at element

2. Click the option Edit element to open the element at the element editor.

3. Make the changes desired and save them.

Seealso

For more information about the element editor, refer to element editor section.

Delete element

Working with collections can only be done from the collections panel. Before starting to work with collections, the
collections panel has to be displayed.

Note

Select Settings > Display > Collections menu item to display the Collections panel.

QElectroTech allows deleting element from some collection. The user has only read rights at QET element collection,
the user can delete element from all collections except QET collection.

1. Right click on the element which should de deleted.
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Figure: Options at element

2. Click the option Delete element to delete the element.

Warning

Be sure about you intention to delete, the element will be deleted from the collectiona and and from the file
system.

Element parts

Line

Create line

The line can only be added to workspace from toolbar.

1. Select the icon  from toolbar to add a line.

2. Click on the initial point from the line in the workspace.

3. Click on the end point from the line in the workspace.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

Line properties

Element part proterties can be displayed from information panel when the part is selected.

Note

If the information panel is not displayed, it can be displayed from Settings > Display > Information.

Figure: QElectroTech line from element

QElectroTech allows customizing different line properties:
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Appearence:
Color: The outline and filling color of the part can be defined from a list of

pre-defined colors. At the case of the line part the filling color is None.

Style: The outline representation type can be chosen between: Normal
(Continuous), Dashed, Dotted or, Dots and dashes.

Thickness: The outline thickness (Weight) can be chosen between: None, Thin,
Normal, Strong or High.

Geometry:
Coordenates: The start and end point coordinates (x, y) can be defined.

End point: The extrem point from the line can be represented individually as:

Normal: The extrem point is represented as the rest of the
line, there is no different representation for the end
point.

Simple arrow: The extrem point is represented as a filled arrow.

Triangle arrow: The extrem point is represented as an empty
triangle arrow.

Circle: The extrem point is represented as an empty
circle.

Diamond: The extrem point is represented as an empty
diamond.

Rectangle

Create rectangle

The rectangle can only be added to workspace from toolbar.

1. Select the icon  from toolbar to add a rectangle.

2. Click on the initial vertex from the rectangle in the workspace.

3. Click on the end vertex from the rectangle in the workspace.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

Rectangle properties

Element part proterties can be displayed from information panel when the part is selected.

Note

If the information panel is not displayed, it can be displayed from Settings > Display > Information.
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Figure: QElectroTech rectangle part from element

QElectroTech allows customizing different rectangle properties:

Appearence:
Color: The outline and filling color of the part can be defined from a list of

pre-defined colors.

Style: The type of outline representation can be chosen between: Normal
(Continuous), Dashed, Dotted or, Dots and dashes.

Thickness: The outline thickness (Weight) can be chosen between: None, Thin,
Normal, Strong or High.

Geometry:
Coordenates: The upper left vertice coordinates (x, y) can be defined.

Dimensions: The width and the height of the rectangle can be defined. The tangent
point at the vertical and horizontal edges can also be defined at the case
that round verteg is desired.

Rounding rectangle vertices

QElectroTech allows rounding the rectangle vertices from information panel or workspace.

Figure: QElectroTech rectangle part from element

Rounding rectangle vertices from information panel

1. Select the rectangle to display the rectangle properties at information panel.

2. Define the distance between the vertice and the intersection point at the vertical edges.

3. Define the distance between the vertice and the intersection point at the horizontal edges.

4. Press intro.

5. Select none from Edit menu or use Ctrl + Shift + a keyboard shortcut.

Rounding rectangle vertices from workspace

1. Select the rectangle drawn at workspace. The rectangle outlines change to red color and the vertices and
middle edge point to blue.

2. Select the rectangle again. The outlines continue in red and the points change to green color.

3. Select the rectangle for third time. The outlines continue in red and only one vertex is displayed, the color is
pink.

4. Displace the pink points arround the horizontal and vertical edge.

5. Select none from Edit menu or use Ctrl + Shift + a keyboard shortcut.
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Ellipse

Create ellipse

The ellipse can only be added to workspace from toolbar.

1. Select the icon  from toolbar to add an ellipse.

2. Click the position from the ellipse center point in the workspace.

3. Click the position from the control point of the ellipse in the workspace.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

Ellipse properties

Element part proterties can be displayed from information panel when the part is selected.

Note

If the information panel is not displayed, it can be displayed from Settings > Display > Information.

Figure: QElectroTech ellipse part from element

QElectroTech allows customizing different ellipse properties:

Appearence:
Color: The outline and filling color of the part can be defined from a list of

pre-defined colors.

Style: The outline representation type can be chosen between: Normal
(Continuous), Dashed, Dotted or, Dots and dashes.

Thickness: The outline thickness (Weight) can be chosen between: None, Thin,
Normal, Strong or High.

Geometry:
Coordenates: The ellipse center point coordinates (x, y) can be defined.

Dimensions: The horizontal and vertical (minimum and maximum or maximum and
minimum) diameters from the ellipse can be defined.

Polygon

Create polygon

The polygon can only be added to workspace from toolbar.
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1. Select the icon  from toolbar to add a polygon.

2. Click on the initial point from the polygon in the workspace.

3. Click on the rest of point from the polygon in the workspace.

4. Doble click on the end position of the polygon to finish the polygon edition.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

Polygon properties

Element part proterties can be displayed from information panel when the part is selected.

Note

If the information panel is not displayed, it can be displayed from Settings > Display > Information.

Figure: QElectroTech polygon part from element

QElectroTech allows customizing different polygon properties:

Appearence:
Color: The outline and filling color of the part can be defined from a list of

pre-defined colors. At the case of an open polygon part the filling color is
None.

Style: The outline representation type can be chosen between: Normal
(Continuous), Dashed, Dotted or, Dots and dashes.

Thickness: The outline thickness (Weight) can be chosen between: None, Thin,
Normal, Strong or High.

Geometry:
Type of

polygon:
QElectroTech has two different types of polygons, open polygon which is
assimilated to a group of connected lines and close polygon which is
assimilated to closed geometry as the rectangle.

Coordenates: The polygon points coordinates (x, y) can be defined and storaged in a
list.

Text field

The normal text field is an object that displays a static text. Once the element has been created, the text can only be
changed if the element is edited. Any different value can be introduced from outside of the element editor.

Create text

The text field can only be added to workspace from toolbar.
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1. Select the icon  from toolbar to add a text field.

2. Click the positional point from the text in the workspace.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

Text properties

Element part proterties can be displayed from information panel when the part is selected.

Note

If the information panel is not displayed, it can be displayed from Settings > Display > Information.

Figure: QElectroTech text field part from element

QElectroTech allows customizing different text properties:

Placement:
Position: The text coordinates (x, y) can be defined.

Text angle: The text display angle can be defined in the range of 0 to 360 degrees.

Content:
Size: The text size can be defined.

Color: The color text can be chosen between balck and white.

Arc

Create arc

The arc can only be added to workspace from toolbar.

1. Select the icon  from toolbar to add an arc.

2. Click at the position from the start point of the arc in the workspace.

3. Click at the position from the end point of the arc in the workspace. The default arc has always an angle of
90 degrees.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.
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Arc properties

Element part proterties can be displayed from information panel when the part is selected.

Note

If the information panel is not displayed, it can be displayed from Settings > Display > Information.

Figure: QElectroTech arc part from element

QElectroTech allows customizing different arc properties:

Appearence:
Color: The outline color and the filling color of the part can be defined from a list

of pre-defined colors. At the case of the arc part the filling color is None.

Style: The type of outline representation can be chosen between: Normal
(Continuous), Dashed, Dotted or, Dots and dashes.

Thickness: The outline thickness (Weight) can be chosen between: None, Thin,
Normal, Strong or High.

Geometry:
Coordenates: The coordinates (x, y) from the ellipse center point can be defined.

Dimensions: The horizontal and vertical (minimum and maximum or maximum and
minimum) diameters from the ellipse can be defined.

Point: The position of initial point and end point are defined as angle of the
radius betuen the center and the respective point with the horizontal
diameter. The angle value follows the mathematical rules, anti-clockwise
for positive angles.

Arc extreme points definition

QElectroTech allows defining the arc extreme points from information panel or workspace.

Figure: QElectroTech arc extreme point

Arc extreme points definition from information panel
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1. Select the arc to display the rectangle properties at information panel.

2. Define the start angle, the angle from the diamete of the start point and the horizontal axes.

3. Define the angle from the initial point and the end point of the arc.

4. Press intro.

5. Select none from Edit menu or use Ctrl + Shift + a keyboard shortcut.

Arc extreme points definition from workspace

1. Select the arc drawn at the workspace. The arc line changes to red color and the control of the arc ellipse
point to blue.

2. Select the arc again. The line continues in red and the points change to green color.

3. Select the arc for third time. The line continues in red and at this time only one extreme points are, the color
is pink.

4. Displace the pink points arround the ellipse outline.

5. Select none from Edit menu or use Ctrl + Shift + a keyboard shortcut.

Terminal

A terminal is a part from the element that will allow a connection with one conductor during the schema creation.

Create terminal

The terminal can only be added to workspace from toolbar.

1. Select the icon  from toolbar to add a terminal.

2. Click on the initial point from the terminal in the workspace to add the terminal.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

Terminal properties

Element part proterties can be displayed from information panel when the part is selected.

Note

If the information panel is not displayed, it can be displayed from Settings > Display > Information.

Figure: QElectroTech terminal part from element

QElectroTech allows customizing different terminal properties:
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Position: The start point coordinates (x, y) can be defined.

Orientation: The exit direction from the connector can be defined. The four possible orientations are North,
East, South and West.

Name: Terminal uuid.

Dynamic text

The dynamic text field is an object that displays a text that is comming from a variable value. The text value is
changing with the variable is changed, editing the part is not necessary to change the text content.

Create dynamic text

The text field can only be added to workspace from toolbar.

1. Select the icon  from toolbar to add a dynamic text field.

2. Click the positional point from the text field in the workspace.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

Dynamic text properties

Element part proterties can be displayed from information panel when the part is selected.

Note

If the information panel is not displayed, it can be displayed from Settings > Display > Information.

Figure: QElectroTech dynamic text field part from element

QElectroTech allows customizing different text properties:

Placement:
Position: The dynamic text coordinates (x, y) can be defined.

Rotation: The text display angle can be defined in the range of 0 to 360 degrees.

Frame: The posibility to display the text inside a rectangle frame is provided.

Alignemnt: The text position inside the frame can be defined. Left, center or right
and top, middle or bottom.

Content:
Source: The source content can be user text (similar to static text), element

information parameter or composite text.

Size: The text size can be defined.

Color: The text color can be choosed from RGB color code database.
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Element cross reference
E-CAD softwares like QElectroTech allow creating projects where different type of subsystems or/and disciplines are
combinated. This means that one device can be represented many times.

An example of combining subsystems is an electrical control system where the command system and the power
system are combined. The control coil from a power contactor is represented at the control command system and the
electrical contactors are represented at the electrical power system.

An example of combining different disciplines is the representation of an hydraulic valve at the electrical schema and
at the hydraulic schema.

The examples mentioned before are situations where different QElectroTech elements introduced at the project are
representing the same device and later on they have to be listed as one item at the Bill Of Materials (BOM). For this
reason, QElectroTech allow defining Master and Slave elements that later on will be linked. The link between master
and slave elements is known at QElectroTech as cross reference.

Cross reference at master element

A master element can have many slave element linked. QElectroTech allows that one master element has more than
one cross reference defined. This characteristic is similar to the physical devices, the component which manage the
control signal can define the action from many different components of the device.

Figure: QElectroTech master element cross reference

The master element is the element which should appear at the Bill of Materials (BOM), it s the element with all the
information. All slave element linked are following the master element.

Cross reference at slave element

A slave element can only have one master element linked. QElectroTech does not allow that one slave element has
more than one cross reference defined.

Figure: QElectroTech slave element cross reference

An slave element has only the properties which defines how the element should be represented, the information from
the element is not necessary, the master element is the element which defines the device and the element which
appear at the bill of materials (BOM), The information about the devce can only be found at the master elemnt.

Element editor

What is the element editor?

The element editor is the editor provided by QElectroTech to modify existing element from the user collection and
create new elements to the collection.
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The element editor is displayed as a PopUP window and looks like the figure below.

Figure: QElectroTech element editor

Interface element editor

Element editor window

The element editor window is a PopUP window from QElectroTech. It has also been designed using Qt framework
and widget toolkit. The window from QElectroTech element editor is the same for all platforms where it is available
(Windows, Linux/Unix and MacOS). The window from the element editor contains the following areas:

1. Menu bar

2. Toolbars

3. Drawing area

4. Panels

5. Help bar

Figure: QElectroTech Element editor window

Element editor menu bar

The menu bar is placed at top from element editor window. The element editor contains the menus File, Edit,
Display, Settings, and Help. Each menu provides many diferent options.
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Note

A brief description of each menu option can be read from help or information tool bar by hovering over the option
with the cursor.

File menu

Figure: QElectroTech file menu

Option Function
Keyboard
shortcut Icon

New Creates a new element Ctrl + n

Open Opens an existing element from collection Ctrl + o

Open from a file Opens an existing element from file Ctrl + o

Starting the DXF
converter pluging

Import element from DXF file Ctrl + o

Recently opened Open an element from history (recently opened files) Ctrl + s

Save Saves the current element changes (overwrites) Ctrl + s

Save as Saves the element as a new element from a library

Save to a file Saves the Element as a different file on disk Ctrl + Shif
t + x

Reload Reloads the opened element (all changes which are
not saved are lost)

Ctrl + p

Quit Quits QElectroTech Element editor Ctrl + q

Edit menu

Figure: QElectroTech edit menu

Option Function
Keyboard
shortcut Icon

Undo Undoes the previous action Ctrl + z

Redo Restores the undone action Ctrl + y

Select All Selects all elments on the folio Ctrl + a
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Select none Deselect all elments on the folio Ctrl + Shift
 + a

Invert selection Inverts selection of elements Ctrl + i

Cut Puts selected elements into the clipboard Ctrl + x

Copy Copies selected elements Ctrl + c

Paste Pastes elements from the clipboard into
the folio

Ctrl + v

Paste in the area Pastes elements from the clipboard into
the folio

Ctrl + v

Paste from Pastes elements from the clipboard into
the folio

Ctrl + v

Delete Removes selected elements from the folio Del

Edit name and information of
the element

Rotates selected elements and texts Space

Edit author information Rotates selected texts to a specific angle Ctrl + Space

Edit element properties Finds the selected element in the
collections panel

Bring to front Brings the selection (s) to front Ctrl + Shift
 + Home

Raise Aproachs the selection (s) Ctrl + Shift
 + Up

Lower Moves away the selection (s) Ctrl + Shift
 + Down

Send backwards Sends in the backwards the selection (s) Ctrl + Shift
 + End

Display menu

Figure: QElectroTech display menu

Option Function
Keyboard
shortcut Icon

Zoom In Expands the workspace Ctrl + +

Zoom Out Shrinks the workspace Ctrl + -

Fit in view Adjusts the zoom on exactly trhe part of the workspace Ctrl + 9

Reset zoom Restores default zoom level Ctrl + 0

Settings menu

Figure: QElectroTech settings menu

Option Function Keyboard shortcut Icon

Display Displays or hides toolbars and panels

Full screen mode Displays QElectroTech in full screen mode Ctrl + Shift + f
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Configure
QElectroTech

Allows specifying various parameters for
QElectroTech

Help menu

Figure: QElectroTech help menu

Option Function
Keyboard
shortcut Icon

What’s This? Enquires main menu options Shift + f1

About QElectroTech Displays information about QElectroTech

Online manual Lauches the default browser to the online manual of
QElectroTech

f1

Youtube channel Lauches the default browser on the Youtube channel of
QElectroTech

Support the project
with a donation

Lauches the default browser on the QElectroTech
donation paypal account

About Qt Displays information about Qt library

Element editor toolbars

In addition to the different menus, QElectroTech provides also toolbars. The toolbars are groups of buttons with
icons which initiate an accion. In general, these buttons have its counterpart at one of the menus from the menu bar.

The different toolbars can be hidden or placed in one or more rows below the menu bar. The toolbars can also be
placed on column at the left or right side from the main window.

Note

To help the user, a tooltip is displayed when the arrow is placed on each button.

Toolbar Tools

Figure: QElectroTech element editor toolbar Tools

The different buttons from toolbar Tools are:

Tool Function
Keyboard
shortcut Icon

New Creates a new element Ctrl + n

Open Opens an existing element from collection Ctrl + o

Save Saves the current element changes (overwrites) Ctrl + s

Save as Saves the element as a new element from a library

Reload Reloads the opened element (all changes which are not saved
are lost)

Ctrl + p

Undo Undoes the previous action Ctrl + z
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Redo Restores the undone action Ctrl + y

Delete Removes selected elements from the folio Del

Note

Select Settings > Display > Tools menu item to display or hidden the toolbar Tools.

Toolbar Display

Figure: QElectroTech element editor toolbar Display

The different buttons from toolbar Display are:

Note

Select Settings > Display > Display menu item to display or hidden the toolbar Display.

Toolbar Element

Figure: QElectroTech element editor toolbar Element

The different buttons from toolbar Element are:

Tool Function Keyboard shortcut Icon

Information Edit name and information of the element Ctrl + e

Properties Edit element properties

Note

Select Settings > Display > Diagrams menu item to display or hidden the toolbar Element.

Toolbar Parts

Figure: QElectroTech element editor toolbar Parts

The different buttons from toolbar Parts are:

Tool Function Keyboard shortcut Icon

Line Add line to the workspace

Rectangle Add rectangle to the workspace

Ellipse Add ellipse to the workspace

Polygon Add polygon to the workspace

Text Add text field to the workspace

Arc Add arc to the workspace
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Terminal Add terminal to the workspace

Text field Add dynamic text field to the workspace

Note

Select Settings > Display > Diagrams menu item to display or hidden the toolbar Parts.

Toolbar Depth

Figure: QElectroTech element editor toolbar Depth

The different buttons from toolbar Depth are:

Tool Function Keyboard shortcut Icon

Bring forward Brings the selection (s) to front Ctrl + shift + H
ome

Raise Aproachs the selection (s) Ctrl + shift + U
p

Lower Moves away the selection (s) Ctrl + shift + D
own

Send backwards Sends in the backwards the selection (s) Ctrl + shift + E
nd

Note

Select Settings > Display > Diagrams menu item to display or hidden the toolbar Depth.

Drawing area

The drawing area or workspace, is the area where the graphical representation of the elements is created.

The drawing area or workspace looks as follow:

Figure: QElectroTech element editor workspace

The scrollbars are not appearing when the element editor is displayed, rolling the wheel from the mouse to zoom in
and th scrollbars will appear.

Element editor panels

Parts panel

The Parts panel lists all parts (lines, terminals, rectangles, dynamic texts, etc.) which make up the element.
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Figure: QElectroTech element editor Parts panel

To display the Parts panel

1. Select Settings > Display > Parts menu item to display the Parts panel.

Selection properties panel

The Selection properties panel displays the appearance and geometry properties from the selected part (line,
terminal, rectangle, dynamic text, etc.).

Figure: QElectroTech element editor Selection properties panel

To display the Selection properties panel:

1. Select Settings > Display > Selection properties menu item to display the Selection properties panel.

Undo panel

The Undo panel lists all actions made by the user inside the element editor from last save.

Figure: QElectroTech element editor Undo panel

To display the Undo panel:

1. Select Settings > Display > Undo menu item to display the Undo panel.

Seealso

For more information about the actions for which the Undo panel can be useful, refer to Undo panel section from
QElectroTech main window.

Help bar

The help bar, also known as information bar, is the space below control tabs, the bottom left corner from main
window. It is very useful for beginners of QElectroTech in the way that it gives information about the field that is
pointed by the cursor. A user can learn about a field by simply pointing it with the mouse and reading the information
from help bar.
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Figure: QElectroTech element editor help bar

Open element editor

QElectroTech allows displaying the element editor PopUP window by creating a new element or by editing an
existing element.

Open element editor by creating a new element

1. Refers to the section link for opening the element editor by creating a new element from the project panel.

Open element editor by editing an element

1. Refers to the section Link for opening the element editor by editing an element from collection onle.

2. Refers to section Link for opening the element editor by editing an element from the workspace.

Save element

The current element can be saved from menu bar, toolbar and using the corresponding keyboard shortcut.

One element is only conformed by one file with format .elmt. The .elmt extension is the native extension from
QElectroTech elements.

Save element from menu bar

1. Select File > Save menu item to save the element changes.
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Figure: QElectroTech element editor file menu

At the case that the opened element has to overwrite an existing element or it has to be saved as a new element:

1. Select File > Save as menu item to display the Save as element PopUP window.

Figure: QElectroTech element editor save as PopUP window

2. Select the element which should be overwrited or the category and the name for the new element.

3. Press the Save button to save the element and close the PopUP window.

The element can also be directly saved as a new file in the Hard Disk directory desired:

1. Select File > Save to a file menu item to display the file system PopUp window.

2. Select the directory and the name from the element file.

3. Press Save button to save the element and close the PopUP window.

Save element from toolbar

1. Select the icon  from toolbar to save the element changes.

At the case that the opened element has to overwrite an existing element or it has to be saved as a new element:

1. Select the icon  from toolbar to display the Save as element PopUP window.

Figure: QElectroTech element editor save as PopUP window

2. Select the element which should be overwrited or the category and the name for the new element.

3. Press the Save button to save the element and close the PopUP window.

Note

If the toolbar is not displayed, it can be displaed from Settings > Display > Tools

Save element using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + s to save the element changes.
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Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Quit element editor

The user can close QElectroTech element editor at any time. The user does not need to save the changes on the
element before closing it.

If the current work wants to be saved before closing the element editor, refer to save section. Even so, QElectroTech
display an automatic message to save the current job if any modification has been created.

Figure: QElectroTech element editor save message

Exit QElectroTech element editor from menu bar

1. Select File > Quit menu item to quit QElectroTech element editor.

Figure: QElectroTech element editor file menu

Exit QElectroTech element editor using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + q to quit QElectroTech element editor.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Create or edit elements

Graphic definition

Working with parts

Add part to element

Adding parts to the drawing area from the element editor can only be done from parts toolbar.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.
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For more information about how to add each type of part (Line, Rectangle, Ellipse, Arc, Polygon, Terminal, text and
dynamic text field), refer to the element part section.

Select parts from workspace

Select one part

At QElectroTech, one part (Line, Rectangle, Ellipse, Arc, Polygon, Terminal, text and dynamic text field) from the
workspace can be selected by a simple left click on the part.

Figure: QElectroTech element editor workspace

Select multiple parts

As many CAD tools, many parts (Line, Rectangle, Ellipse, Arc, Polygon, Terminal, text and dynamic text field) from
workspace can be selected at the same time.

Select multiple objects using keyboard and mouse

QElectroTech allows selecting multiple parts from the workspace combining the use of the keyboard and mouse.

1. Select the first part.

2. Press Ctrl.

3. Select the rest of parts without releasing Ctrl.

Figure: QElectroTech schema

Select multiple objects by selecting area

QElectroTech allows selecting all parts from a defined area using the mouse.

1. Left click on the initial point from the rectangular area to be selected and displace the mouse without
releasing the button.

Figure: QElectroTech selecting on workspace

Select all Parts

QElectroTech allows selecting all parts from the workspace, all parts from the opened element, at the same time.
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All parts can be selected from menu bar, workspace or using the corresponding keyboard shortcut.

Select all parts from menu bar

1. Select Edit > Select all menu item to select all parts from the opened element.

Figure: QElectroTech Edit menu

Select all parts from workspace

As many other CAD tools, QElectroTech allows selecting all parts from the workspace using the mouse.

1. Left click on the initial point from the rectangular area to be selected and displace the mouse without
releasing the button.

Figure: QElectroTech element editor selecting on workspace

Select all objects using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + a to select all parts from the opened element.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Select none

To be sure that any part is selected before any action, QElectroTech provides the option to unselect all parts from
the workspace. This option is useful for avoiding undesired changes.

Unselecting all parts can be done from menu bar or using the corresponding keyboard shortcut.

Select none from menu bar

1. Select Edit > Select none to unselect all selected parts.
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Figure: QElectroTech element editor Edit menu

Select none using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + Shift + a to unselect all selected parts.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Invert the selection

Some times is easier to select the parts from the workspace which are not interested for the desired action than the
parts which should be selected. For this reason, QElectroTech provides the option to invert the selection.

Inverting the selection can be done from Menu bar or using the corresponding keyboard shortcut.

Invert selection from menu bar

1. Select the part/s from the opened element which are not interested for the desired action.

2. Select Edit > Invert selection to invert the selection.

Figure: QElectroTech Edit menu

Invert selection using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the part/s from the opened element which are not interested for the desired action.

2. Press Ctrl + i to invert the selection.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.
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Cut part

QElectroTech element editor allows cutting the different possible type of parts to paste them later on at different
place from the element editor workspace.

Note

Multiples parts can be cut at the same time, pressing Ctrl is necessary to select more than one part.

Cutting parts can be done from menu bar, by right click on the part and from the corresponding keyboard shortcut.

Cut part from menu bar

1. Select the part which should be cut.

2. Select Edit > Cut menu item to cut the part.

Figure: QElectroTech Edit menu

Cut part by right click

1. Right click on the part which should be cut.

2. Select the option Cut to cut the part.

Figure: QElectroTech right click PopUP window

Cut part using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the part which should be cut.

2. Press Ctrl + x to cut the part.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.
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Copy part

QElectroTech element editor allows copying the different possible type of parts to paste them later on at different
place from the element editor workspace.

Note

Multiples parts can be copied at the same time, pressing Ctrl is necessary to select more than one part.

Copying parts can be done from menu bar, by right click on the part and using the corresponding keyboard shortcut.

Copy part from menu bar

1. Select the part which should be copied.

2. Select Edit > Copy menu item to copy the part.

Figure: QElectroTech element editor Edit menu

Copy part by right click

1. Right click on the part which should be copied.

2. Select the option Copy to copy the part.

Figure: QElectroTech right click PopUP window

Copy part using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the part which should be copied.

2. Press Ctrl + c to copy the part.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.
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Paste part

QElectroTech element editor allows pasting the different possible type of parts which have already been copied or
cut from the drawing area.

Note

Multiples parts can be pasted at the same time, check copy part or cut part section to check how multiples parts
can be copied or cut.

Pasting parts can be done from menu bar, by right click on the drawing area and using the corresponding keyboard
shortcut.

Paste part from menu bar

1. Select Edit > Paste menu item to paste the part copied or cut previously from drawing area.

Figure: QElectroTech element editor Edit menu

Paste part by right click

1. Right click somewhere from drawing area.

2. Select the option Paste to paste the part copied or cut previously.

Figure: QElectroTech right click PopUP window

Paste part using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + v to paste the part copied or cut previously from drawing area.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Note

The procedure defined at this section only allows pasting the parts at the right grid point from the copied or cut
part position. To be able to choose the place where the part has to be pasted, refer to paste in area section.
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Paste in area

Past in area is similar command to paste part, the main diference is the place where the part can be pasted. At
normal paste command QElectroTech pastes the part automatically at a predefined position, at paste in area
command the user is free to choose the place where the object has to be pasted by using left clik on the desired
place.

Pasting parts in area can be done from menu bar, by right click on the drawing area and from the corresponding
keyboard shortcut.

Paste part from menu bar

1. Select Edit > Paste in the area… menu item to paste the part copied or cut previously from drawing area.

2. Left click at the Drawing area point where the part should be pasted.

Figure: QElectroTech Edit menu

Paste part by right click

1. Right click somewhere from drawing area.

2. Select the option Paste in the area… to paste the part copied or cut previously.

3. Left click at the drawing area point where the part should be pasted.

Figure: QElectroTech right click PopUP window

Paste part using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + Shift + v to paste the part copied or cut previously from drawing area.

2. Left click at the Drawing area point where the part should be pasted.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Paste from

Delete part

QElectroTech element editor allows deleting parts which has been added or pasted at the element editor workspace
previously.
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Deleting parts can be done from menu bar, toolbar, by right click on the part and using the corresponding keyboard
shortcut.

Delete part from menu bar

1. Select the part which should be deleted.

2. Select Edit > Delete menu item to delete the part from workspace.

Figure: QElectroTech element editor Edit menu

Delete part from toolbar

1. Select the part which should be deleted.

2. Select the icon  from the toolbar to delete the part from workspace.

Note

If the toolbar is not displayed, it can be displaed from Settings > Display > Tools

Delete part by right click

1. Right click on the part which should be deleted.

2. Select the option Delete to delete the part from workspace.

Figure: QElectroTech right click PopUP window

Delete part using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the part which should be deleted.

2. Press Del to delete the part from workspace.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.
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Layers in element editor

Overlaping of parts, graphical elements, may occur at the graphical representation of elements. QElectroTech allows
defining the representation order from part. Working with layers will be necessary, for example, when a filled part as
rectangle or ellipse hides a text.

The definition of layer level from each part can only be done from menu bar.

1. Select the part which layer level should be defined.

2. Select Edit from the main bar and the desired layer action.

Figure: QElectroTech element editor Edit Menu

Regarding the layer actions allowed by QElectroTech, the following table defines all possibilities.

Icon Action Definition Keyboard shortcut

Bring to
front

Brings the selection (s) to front Ctrl + Shift + 
Home

Raise Aproachs the selection (s) Ctrl + Shift + 
Up

Lower Moves away the selection (s) Ctrl + Shift + 
Down

Send bac
kwards

Sends in the backwards the selection (s) Ctrl + Shift + 
End

Change element size

QElectroTech provide the feature of changing the size of the graphical symbol from an element. This feature is
equivalent to the scale feature from CAD tools and graphical vector editors.

Note

The current version from QElectroTech, version 0.7, does not provide the option of defining the proportion to
scale.

To changee the size from element symbol:

1. Open the element desired using the element editor.

2. Select all element parts from workspace.

3. Press one of the control points from the global element symbol rectangle (green points from the figure).
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Figure: QElectroTech element editor workspace

4. Move the point without releasing the left button of the mouse.

5. Once the element symbol has been scaled, save changes and close element editor.

Element properties definition

Define element name

The element name is used to identify the element at QElectroTech. The name has no relation with the element file
name, they can be completely different. The name file is the name from the file which contains the information from
the element. The element name is the name which represents the element in the different collection.

The element name can be defined in many different languages. Depending on the chosen language at QElectroTech
settings, the name is displayed for the user at one language or at another.

Figure: QElectroTech element name PopUP window

Note

QElectroTech works according ISO 639-1 norm. The text language is defined using 2 letters code which should
be used at the Language column from the cell value table.

Define element name from menu bar

1. Select Edit > Edit name and information of the element menu item to display the name editor PopUp
window.

Figure: QElectroTech element editor Edit Menu

2. Press the button + Add a line to introduce a new row at the element name table.
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3. Define the 2 letters code language at Language column.

4. Define the element name with the defined language at Text column.

5. Press the button OK to accept and close the name editor PopUp window.

Define element name from toolbar

1. Press the icon  from the toolbar to display the name editor PopUp window.

2. Press the button + Add a line to introduce a new row at the element name table.

3. Define the 2 letters code language at Language column.

4. Define the element name with the defined language at Text column.

5. Press the button OK to accept and close the name editor PopUp window.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Element.

Define element name using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + e to display the name editor PopUp window.

2. Press the button + Add a line to introduce a new row at the element name table.

3. Define the 2 letters code language at Language column.

4. Define the element name with the defined language at Text column.

5. Press the button OK to accept and close the name editor PopUp window.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Define author element information

Define author element information from menu bar

1. Select Edit > Edit author information menu item to display the author information PopUp window.

Figure: QElectroTech element editor Edit Menu

2. Introduce the desired information to the text box.

3. Press the button OK to accept and close the author information PopUp window.
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Define author element information using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + y to display the author information PopUp window.

2. Introduce the desired information to the text box.

3. Press the button OK to accept and close the author information PopUp window.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Edit element properties

Edit element properties from menu bar

1. Select Edit > Edit element properties menu item to display the element properties PopUp window.

Figure: QElectroTech element editor Edit Menu

2. Select the element family, the base type from the element, at Type tab.

Figure: QElectroTech element properties Type tab

For simple, master or terminal block elements:

3. Go to Informations tab.

Figure: QElectroTech element properties Information tab

4. Fill each predefined field with the desired information.

5. Press the button OK to accept and close the element properties PopUp window.
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For slave or reference folio elements:

3. Press the button OK to accept and close the element properties PopUp window.

Edit element properties from toolbar

1. Press the icon  from toolbar to display the element properties PopUp window.

2. Follow same procedure defined at the previous section starting from step 2.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Element.

Conductor

What is a conductor?
A conductor or conduit represents the means of transmission of information, electrical power, flow power (pressure
or flow volume) between source and target.

Figure: QElectroTech conductor

In physical systems, T-crosses are uset at fluid lines and terminal blocks are used to feed different electrical devices
from the same source. QElectroTech also allows multiple connections between source and target.

Type of conductor

Single line conductor

The single line conductors is used at single line diagrams. Single line conductors are the simplified notation for
representing two and three phase power system drawing using a common conductor. Single line conductors are only
used to represent power systems, control systems are normally not represented.

Note

At fluid power schemas, the pressure and return line are represented by the same conductor.

QElectroTech does not allow defining any conductor property at single line conductor. The single line conductor does
not have the posibility of text linking.
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Figure: QElectroTech single line conductors

The most common sigle line conductors used at single line diagrams of power electric systems are:

Figure: Common single line conductors

Multiline conductor

Multiline conductors are used at multiline diagrams. Multiline conductors are used for the representation of each
terminal, line and phase from two and three phase power systems. Multiline conductors are used for the individual
representation of all electric and control systems.

Note

At fluid power schemas, a multiline conductor represents each pressure, return and pilote line.

The main difference of multiline with respect to single line conductors is the posibility to display text which is linked to
the conductor properties.
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Figure: Multiline conductor

The main features of multiline conductors are:

1. Possibility to define properties (Function and voltage/protocol)

2. Text linked to the conductor which can be displayed and its position is relative to the conductor position.

3. Possibility of displaying variables values at the conductor text (Auto numbering, function or
voltage/protocol).

4. Possibility of using the conductor variables at element dynamic text (Function and voltage/protocol).

Conductor properties

Display conductor properties

The conductor properties window can be displayed from menu bar, from workspace and using the corresponding
keyboard shortcut.

Display conductor properties from menu bar

1. Select the conductor which properties should be displayed.

2. Select Edit > Edit conductor menu item to display the conductor properties PopUP window.

Figure: QElectroTech Edit menu

Display conductor properties from workspace

1. Right click on the conductor which properties should be displayed.

2. Select Edit conductor option to display the conductor properties PopUP window.
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Figure: QElectroTech conductor options

Display conductor properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the conductor which properties should be displayed.

2. Press Ctrl + e to display the conductor properties PopUP window.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Conductor type

Multiline conductor

For multiline conductors, QElectroTech allows defining many different parameters from the conductor. The
parameters which can be defined are:

• Display parameters:

1. Text size: Size of the displayed text.

2. Text formula: To be used if a variable value is desired at the Text field during conductor creation.

3. Text: Text field content to be displayed at folio.

4. Text color: Font color to be displayed at folio.

5. Positioning and orientation from the displayed text at folio, vertical and horizontal conductors.

• Conductor properties:

6. Function: Variable from conductor, it is used to define the wire phase (L1, L2, L3, N, etc.).

7. Voltage / Protocol: Variable from the conductor, it is used to define the wire voltage (0v,230V,400V,
6kV, etc.) or the wires network protocol (IP).

8. Conductor color: Variable from the conductor, it is used to define the wire color.

9. Conductor section: Variable from the conductor, it is used to define the wire section.

10. Cable:

11. Bus:

Figure: Multiline conductor properties
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Note

Displaying the conductor TAG (code) at multiline diagrams is usual for an easily manage of the manufacturing,
erection, commissioning and maintenance phase of the product.

QElectroTech allows an automatic conducto number definition for the text using the variable %autonum at the
Text formula field. This field have to be defined at Folio properties before starting the conductor creation.

Single line conductor

For single line conductors, the conductors are represented without any text infromation. Only the type of power
system should be defined to have the correct symbol representation.

QElectroTech allows the following options for single line conductors:

1. System with or without Ground

2. System with or without Neutral

3. PEN system, system where Neutral and Ground are the same wire.

4. Systems with one, two or three phases

Figure: Single line conductor properties

Conductor appearance

The color, type and width from the line of the schema that represents the conductor can be defined. A line can have
a main color and, if desired, a secondary color.

Note

The secondary line is used when a dashes line with double color is desired.

Figure: Conductor with red secundary color
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Figure: Multiline conductor appearance

• The different types of lines are: Solid, Dashed and Dots and dasches.

• The possible colors are defined by the RGB scale range.

• The possible line thiknes are between 0.4 and 10 mm (0.4, 0.6, 0.8, 1.0, 1.2, 1.4, 1.6, … , 10).

Note

QElectroTech provides the option to pre-define the appearance of conductor before starting to draw conductos at
the folio. This feature increase the working eficiency and avoid defining the appearence conductor by conductors
after their creation.

For more information about appearance pre-definition, refer to folio properties section.

Conductor numbering

QElectroTech allows an automatic codification of conductors. This feature is very usefull for the creation of reports,
conductor list, and for the identification of conductors at the physical systems and schemas.

QElectroTech allows the definition of multiples auto numbering patterns. It also provides many flexibility on the
creation of auto numbering patterns using text, variables and sequential numbers.

Figure: QElectroTech conductor auto numbering

Example

Taking the content from the image above:
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W X XX XXX N

W: Code defined by IEC 81346 norm.

• W: Guiding or transporting from one place to another.
X: Alphanumeric code corresponding to the following coding:

• H: High voltage

• B: 400 V AC

• C: 230 V AC

• D: Digital signal

• A: Analog signal

• @: Network
XX: Installation or functional unit to which the cable belongs (schema where the cable can be

found).

• 001: Incoming plant

• 002: Global auxiliary power

• 003: Distribution Network

• 004: instalation 1

• 005: installation 2

• …

• 999: …
XXX: Folio where the cable is represented.

N: Cable number.

Seealso

For more information about how to define auto numbering patterns, refer to project auto numbering properties
section.

For more information about how to manage the codification of conductors, refer to create conductor section.

Schema

What is a schema?

Working with elements

Add element

To add an element to the workspace:

1. Select auto numbering pattern at the Auto numbering selection panel.

Schema

138

https://www.iso.org/standard/50858.html
file:///home/hude/Documents/schema/index.html
file:///home/hude/Documents/project/properties/numbering_prop.html
file:///home/hude/Documents/schema/conductor/conductor_creation.html
file:///home/hude/Documents/element/index.html
file:///home/hude/Documents/interface/workspace.html
file:///home/hude/Documents/conductor/properties/conductor_numbering.html
file:///home/hude/Documents/interface/panels/autonumbering_panel.html


Figure: QElectroTech Auto numbering selection panel

Note

If the Auto numbering selection panel is not displayed, it can be displayed from Settings > Display
> Auto numbering selection.

2. Search the element at the collection panel.

3. Left Click on the desired element. Without releasing move the mouse to the workspace area, onece the
mouse is at the workspace it can be released.

4. Search for the desired element position and left clik on the place to add the element, multiples elements
can be added with multiple clicks at different places.

5. Press esc to finish the adding action.

Note

Select Settings > Display > Collections menu item to display the collections panel.

Edit element

To edit an element:

1. Display element properties at selection properties panel.

2. Go to general properties tab and click on the button Edit element to display element editor.
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Figure: QElectroTech general element properties

Note

If the selection properties panel is not displayed, it can be displayed from Settings > display > Selection
properties.

Seealso

For more information about how to edit elements, refer to element editor section.

Working with cross reference

Bind slave item

It can happen that one device should be represented in the project using different elements, power and control
subsystem and auxiliary subsystems. All these elements should be considered as one device. QElectroTech works
with master and slave elements which are linked using cross references to represent the device.

A slave element can be linked to a master element with the following steps:

1. Select the master element which should be linked from the project collection or from the workspace.

2. Right click on the selected element and choose the option Edit the element.

Figure: QElectroTech element options

3. Display the Cross-reference (Master) tab from the element editor PopUP window.

Figure: QElectroTech cross reference tab element properties
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4. Search and select the desired slave element from the Availabel elements table.

5. Press Bind item  to link the slave element to the master element.

6. Press Apply to accept and save the changes.

Note

At the avaliable elements table, the slave element can also be linked by right click on the element and selectimg
the option Link the item.

Figure: QElectroTech cross reference tab element properties

Bind master item

It can happen that one device should be represented in the project using different elements, power and control
subsystem and auxiliary subsystems. All these elements should be considered as one device. QElectroTech works
with master and slave elements which are linked using cross references to represent the device.

A master element can be linked to a slave element with the following steps:1. Select the Slave element which should be linked from the project collection or from the workspace.

2. Right click on the selected element and choose the option Edit the element.

Figure: QElectroTech element options

3. Display the Cross-reference (Slave) tab from the element editor PopUP window

Figure: QElectroTech cross reference tab element properties

4. Search and select the desired master element from the available master elements table.

5. Right clik on the master element and select the option Link the item to link the master element to the slave
element.
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Figure: QElectroTech cross reference tab element properties

6. Press Apply to accept and save the changes.

Untie slave item

Some times is necessary to delete previous work, QElectroTech allows breaking/deleting links between elements
(cross references).

A Slave element can be unlinked from a master element as follow:

1. Select the master element which should be unlinked from the project collection or from the workspace.

2. Right click on the selected element and choose the option Edit the element.

Figure: QElectroTech element options

3. Display the Cross-reference (Master) tab from the element editor PopUP window

Figure: QElectroTech cross reference tab element properties

4. Search and select the desired slave element from the Element related table.

5. Press the Untie item button  to unlink the slave element from the master element.

6. Press Apply to accept and save the changes.

Note

The slave element can also be unlinked by right clik on the element and selecting the option Unlink the item.
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Figure: QElectroTech cross reference tab element properties

Untie master item

Some times is necessary to delete previous work, QElectroTech allows breaking/deleting links between elements
(cross references).

A master element can be unlinked from a slave element as follow:

1. Select the Slave element which should be unlinked from the project collection or from the workspace.

2. Right click on the selected element and choose the option Edit the element.

Figure: QElectroTech element options

3. Display the Cross-reference (Slave) tab from the element editor PopUP window

Figure: QElectroTech cross reference tab element properties

4. Press Unlink to delete the cross reference with the master element.

5. Press Apply to accept and save the changes.

Show linked item

On of the advantages of working with cross references on E-CAE tools like QElectroTech is the posibility to find the
linked elements automatically. QElectroTech allows finding a linked element easily.

If the master and slave/s element/s are at the same folio, only by placing the mouse at one element, the other/s will
be remarked in blue. The linked element/s can also be found from the element properties.
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Figure: QElectroTech elements cross reference

At the case that the elements are at different folios, the linked element/s can only be found from the element
properties.

Show slave linked item

1. Select the slave element which should be linked from the project collection or from the workspace.

2. Right click on the element selected and choose the option Edit the element.

Figure: QElectroTech element options

3. Display the Cross-reference (Slave) tab from the element editor PopUP window
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Figure: QElectroTech cross reference tab element properties

4. Search and select the desired slave element from the Element related table.

5. Right clik on the slave element and select the option Show item to find and display the master element.

Figure: QElectroTech cross reference tab element properties

Show Master linked item

1. Select the slave element from the project collection or from the workspace.

2. Right click on the selected element and choose the option Edit the element.

Figure: QElectroTech element options

3. Display the Cross-reference (Slave) tab from the element editor PopUP window

Figure: QElectroTech cross reference tab element properties

4. Press See the linked item to find and display the master element.

Working with conductors

Create conductor

Manual conductor creation

To create a conductor manually:

1. Select auto numbering pattern at the Auto numbering selection panel.
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Figure: QElectroTech Auto numbering selection panel

Note

If the Auto numbering selection panel is not displayed, it can be displayed from Settings > Display
> Auto numbering selection.

2. Click on the initial terminal from the conductor.

3. Without releasing, move the mouse up to the end terminal of the conductor.

4. Once the end terminal is automatically identified by QElectroTech, release the mouse to create the
conductor.

Figure: QElectroTech manual conductor creation

Automatic conductor creation

To increase the working eficiency, QElectroTech can create conductors automatically when an element is added to
the workspace.

To create a conductor automatically:

1. Select auto numbering pattern at the Auto numbering selection panel.
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Figure: QElectroTech Auto numbering selection panel

Note

If the Auto numbering selection panel is not displayed, it can be displayed from Settings > Display
> Auto numbering selection.

2. Select the icon  from toolbar, if it is not selected.

3. Add element to workspace taking care of the element position, the initial terminal and the end terminal
have to be at the same vertical or horizontal line.

Figure: QElectroTech automatic conductor creation

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.
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Warning

At the case that the initial and end terminal are different potentials, QElectroTech considers two terminals from
the same element as different potentials, QElectroTech will inform by a warning PopUP window. Nevertheless,
QElectroTech will create the conductor

Figure: QElectroTech different potentials warning

Modify conductor

QElectrotech draws by default a conductor minimizing the horizontal and vertical lines. Changing the route of the
conductor for a clear understanding of the schema is some times necessary. QElectroTech allows modifying the
route.

Figure: QElectroTech modify conductor

To modify the route of a conductor:

1. Select the conductor which route should be modified.

2. Press on a control point, blue points, from the conductor selected.

3. Without releasing the control point, displace the control point horizontally or vertically until desired position.

Reset conductors

QElectroTech provides the posibility to return to the default route once a conductor route has been modify.
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Figure: QElectroTech reset conductor

QElectroTech allows resetting the route of a conductor from menu bar, toolbar, workspace or using keyboard
shortcut.

Reset conductor from menu bar

1. Select the conductor which route should be reseted.

2. Select Edit > Reset conductors menu item to reset the conductor route.

Figure: QElectroTech edit menu

Reset conductor from toolbar

1. Select the conductor which route should be reseted.

2. Select the icon  from toolbar to reset the conductor route.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

Reset conductor from workspace
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1. Right click on the conductor which route should be reseted.

2. Select the option Reset conductors to reset the conductor route.

Figure: QElectroTech conductor options

Reset conductor using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the conductor which route should be reseted.

2. Press Ctrl + k to reset the conductor route.

Seealso

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

Define text at conductor

QElectroTech allows defining and displaying information text at each conductor.

Note

Only multiline conductors allow text definition.

To define the conductor text:

1. Select the conductor which should be edited.

2. Display conductor properties PopUp window.

3. Go to multiline section from Type tab.

Figure: QElectroTech multiline conductor text section

4. Choose the desired parametes for text positioning, text content or formula, text size, etc.

5. Click the check buttom Apply properties to all conductor of this potential if the changes should be
applied for all conductor with common initial or end terminal.

6. Press OK button to save and apply the property changes.
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Seealso

For more information about multiline properties, refer to conductor type properties section.

For more information about automatic text definition during conductor creation, refer to project folio properties
section.

Change appearance conductor

QElectroTech allows changing the conductors appearance, the line style and color can be defined for each
conductor.

To change the conductor appearance:

1. Select the conductor which should be edited.

2. Display conductor properties PopUp window.

3. Go to Appearance tab.

Figure: QElectroTech conductor appearance PopUP window

4. Choose the desired parameters for main color and secondary color if necessary.

5. Click the check buttom Apply properties to all conductor of this potential if the changes should be applied
for all conductor with common initial or end `terminal`_. 5. Click or unclick the option Apply properties to all
conductors of this potential. 6. Press OK button to save and apply the property changes.

Seealso

For more information about conductor appearance, refer to conductor appearance section.

Working with text field

Insert text field

Note

To draw more easily, the folio grid can be displayed from Display > Display the grid or from toolbar icon .

The text field can only be added to the workspace by toolbar.

1. Select the icon  from toolbar.
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2. Click on the workspace place point where the text field should be placed.

3. Write the desired text.

4. Click anywhere from the workspace to top the edition process and save the text content.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

Edit text field

Edit text field from menu bar

1. Select the text field which should be edited.

2. Select Edit > Edit the selected object menu item to display the text editor PopUP window.

Figure: QElectroTech edit menu

Edit text field by right click

1. Right click on the text field which should be edited.

2. Select the option Edit the text field to display the text editor PopUP window.

Figure: QElectroTech text field options

Edit text field from selection properties panel

1. Select the text field which should be edited.

2. Click on Advanced Editor button from selection properties panel to display the text editor PopUP window.

Figure: QElectroTech text field selection properties panel
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Note

If the selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties

Edit text field using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the text field which should be edited.

2. Press Ctrl + e to display the text editor PopUP window.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Text editor

The text editor from QElectroTech allows two different philosophy to introduce text in the workspace:

1. What You See Is What You Get (WYSIWYG)

2. HTML code to create content and define format.

Rich text tab

The Rich text tab is used when the WYSIWYG philosophy is applied. The different options from the rich text are:

1. Definition of content.

2. Definition of font color.

3. Definition of font size.

4. Definition of aditional font options (underlinel, bold and italic style, superscript, subscript)

Figure: QElectroTech Text editor rich text tab

Source tab

The source tab is used when the text content and the format is defined using HTML code. QElectroTech processes
internally the HTML code and compiles the result to be shown. The formatting limits are at HTML code.
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Figure: QElectroTech Text editor source tab

Move text

A text field is considered on object more in the workspace. A text field can be move arround the workspace using the
mouse or the keyboard like elements, basic objects or pictures.

Move text field by mouse

1. Left clik on the text field which should be moved.

2. Without releasing, move the mouse to the new desired position.

Move text field from selection properties panel

1. Select the text field which should be moved.

2. Define coordinates X and Y from text field at selection properties panel.

Figure: QElectroTech text field selection properties panel

Note

If the selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties

Move text field by keyboard

1. Select the text field which should be moved.

2. Press the corresponding arrow (Downwards, Rightward, Leftwards or Upwards) to move the text field
one grid row or column.

Rotate text

The content from a text field can be rotated in two different ways:

1. Rotating the text field as an object.

2. Defining the text orientation inside the text field.

Rotate text field

The text field is considered an object by QElectroTech, it can be selected, placed and rotated as elements and
pictures. It can be rorated 90, 180 or 270 degrees.

1. Right click on the text field which should be rotated.
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Figure: QElectroTech text field options

2. Select the option Rotate to rotate the text field 90 degrees on the clock direction.

Seealso

For more information about rotating objects at the workspace, refer to rotate object section.

Define text orientation

Defining the text orientation rotates only the content from the text field. The advantage of choosing the text
orientation is the possibility to choose any angle between -360 and 360 degrees.

Define text orientation from workspace

1. Right click on the text field which should be oriented.

Figure: QElectroTech text field options

2. Select the option Choose text orientation to display the text orientation PopUP window.

Figure: QElectroTech choose orientation PopUP window

3. Define the orientation angle of the text.

4. Press OK to save the changes.

Define text orientation from selection properties panel

1. Select the text field which should be oriented.

2. Define the orientation angle of the text at Angle field from selection properties panel.

Figure: QElectroTech text field selection properties panel

Note

If the selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties
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Insert URL link

QElectroTech works with text as html code. This property allows the user introducing at the workspace anything that
is possible with HTM code. This section explains how the user can create an URL link for a text.

Note

The URL link is only actived at the PDF version of the document. The link is not actived at the native
QElectroTech format.

At the current released version, version 0.7, QElectroTech allows creating an URL link internally or using external
html code generators.

Insert URL link from QElectroTech text editor

1. Display the text editor by editing the desired text field.

Figure: QElectroTech Text editor rich text tab

2. Press the icon Insert link from the Menu bar for displaying the Insert link PopUP window.

Figure: QElectroTech insert link PopUP window

3. Define the text which should be displayed at the workspace and the desired URL where the link should
redirect.

4. Press the button OK to close the Insert link PopUP window and add the link to the text field content.

5. Press the button OK to save the text field content and close the text editor.

Insert URL link using external html code generators

At the case that something special should be included or any propertie should be different, QElectroTech allows
creating the html source code using an external code generator and later on introduce the code.

1. Display the text editor by editing the desired text field.

Figure: QElectroTech Text editor rich text tab

2. Select the source Tab.
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Figure: QElectroTech Text editor source tab

3. Copy the html code from the html code generator.

4. Press the button OK to save the text field content and close the text editor.

Note

Many different HTML Table Generator can be found on interned or can be installed at the computer. One internet
example is the following:

https://html-css-js.com/html/generator/

Insert table
QElectorTech 0.7 does not have any tool or menu item which creates tables with the number of rows and columns
desired automatically. QElectroTech allows importing HTML text, this is the way to create tables.
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1. Select icon Add textfield  from the toolbar.

2. Click on the area from the workspace where the table should be created.

3. Right click on text field and choose Edit the text field option.

Figure: QElectroTech text field option

4. Choose the source tab from the text field editor.

Figure: Source tab text field editor

5. Copy the html code generated by the HTML Table Generator.

6. Choose the Rich Text tab from the text field editor.

Figure: Rich text tab text field editor

7. Fill the headers and cells with the corresponding information.

8. Press OK button and the table will be created at the workspace.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

The table can be moved and rotated over the folio area like a text field, it is a text field object.

Note

Many different HTML Table Generator can be found on interned or can be installed at the computer, an online
option is:

https://www.quackit.com/html/html_table_generator.cfm

Basic objects
In addition to working with elements and conductors, QElectroTech also allows drawing primitive 2D geometries
(line, rectangle, ellipse and polygon) at the workspace.
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Line

Create line

Note

To draw more easily, the folio grid can be displayed from Display > Display the grid or from toolbar icon .

A line can only be added to the workspace by toolbar.

1. Select the icon  from toolbar to add a line.

2. Click on the initial point from the line.

3. Click on the end point from the line.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

Line properties

QElectroTech allows customizing the type of line, the thikness from the line and the color of the line.

• The different types of lines are: normal, dashed, dotted, dots and dasches, dash dot dot and custom
dash line.

Figure: QElectroTech Color selection PopUP window

• The possible line thiknes are between 0.2 and 50 mm (0.2, 0.4, 0.8, 0.6, 0.8, 1, 1.2, 1.4, … , 50).

• The possible colors are defined by the RGB scale range.

Note

The position from the line can be locked to prevent involuntary movement.

• Go to line properties and check the Lock position button.

The line properties can be displayed from menu bar, by right click on the line, from selection properties panel and
using keyboard shortcut.

Line properties from menu bar

1. Select the line which should be edited.

2. Select Edit > Edit the selected object menu item to display the line properties PopUP window.
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Figure: QElectroTech edit menu

Line properties by right click

1. Right click on the line which should be edited.

2. Select the option Edit the selected object to display the line properties PopUP window.

Figure: QElectroTech line selection PopUP window

Line properties from selection properties panel

1. Select the line which should be edited and the properties from the line will appear at selection properties
panel.

Figure: QElectroTech Line properties panel

Note

If the selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties

Line properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the line which should be edited.

2. Press Ctrl + e to display the line properties PopUP window.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Schema

160

file:///home/hude/Documents/interface/panels/selection_properties_panel.html
file:///home/hude/Documents/interface/panels/selection_properties_panel.html
file:///home/hude/Documents/interface/panels/selection_properties_panel.html
file:///home/hude/Documents/interface/menu_bar.html


Rectangle

Create rectangle

Note

To draw more easily, the folio grid can be displayed from Display > Display the grid or from toolbar icon .

The rectangle can only be added to the workspace by toolbar.

1. Select the icon  from toolbar to add a rectangle.

2. Click on the initial vertix from the rectangle.

3. Click on the end vertex from the rectangle.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

Rectangle properties

The edges and the internal area from the triangle can be costumized at QElectroTech.

• The edges from a rectangle have the same properties as a line.

• The type of filling for closed primitive objects (rectangle, ellipse and closed polygon) are: None, Solid line
and some types of grids.

Figure: QElectroTech Color selection PopUP window

• The possible filling colors are defined by the RGB scale range.

Note

The position from the rectangle can be locked to prevent involuntary movement.

• Go to rectangle properties and check the Lock position button.

The rectangle properties can be displayed from menu bar, by right click on one rectangle edge, from selection
properties panel and using keyboard shortcut.

Rectangle properties from menu bar

1. Select one of the edges from the rectangle which should be edited.
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2. Select Edit > Edit the selected object menu item to display the rectangle properties PopUP window.

Figure: QElectroTech edit menu

Rectangle properties by right click

1. Right click on one of the edges from the rectangle which should be edited.

2. Select the option Edit the selected object to display the rectangle properties PopUP window.

Figure: QElectroTech rectangle selection PopUP window

Rectangle properties from selection properties panel

1. Select one of the edges from the rectangle which should be edited and the properties from the rectangle
will appear at selection properties panel.

Figure: QElectroTech Rectangle properties panel

Note

If the selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties

Rectangle properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select one of the edges from the rectangle which should be edited.

2. Press Ctrl + e to display the rectangle properties PopUP window.
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Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Ellipse

Create ellipse

Note

To draw more easily, the folio grid can be displayed from Display > Display the grid or from toolbar icon .

The ellipse can only be added to the workspace by toolbar.

1. Select the icon  from the toolbar to add an ellipse.

2. Click on the initial controlling point from the ellipse.

3. Click on the end controlling point from the ellipse.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

Ellipse properties

The border line and the internal area from the ellipse can be costumized at QElectroTech.

• The border line from a ellipse has the same properties as a line.

• The type of filling for closed primitive objects (rectangle, ellipse and closed polygon) are: None, Solid line
and some types of grids.

Figure: QElectroTech Color selection PopUP window

• The possible filling colors are defined by the RGB scale range.

Note

The position from the ellipse can be locked to prevent involuntary movement.

• Go to ellipse properties and check the Lock position button.

The ellipse properties can be displayed from menu bar, by right click on border from the ellipse, from selection
properties panel and using keyboard shortcut.
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Ellipse properties from menu bar

1. Select the border from the ellipse which should be edited.

2. Select Edit > Edit the selected object menu item to display the ellipse properties PopUP window.

Figure: QElectroTech edit menu

Ellipse properties by right click

1. Right click on the border from the ellipse which should be edited.

2. Select the option Edit the selected object to display the ellipse properties PopUP window.

Figure: QElectroTech ellipse selection PopUP window

Ellipse properties from selection properties panel

1. Select one the border from the ellipse which should be edited and the properties from the ellipse will
appear at selection properties panel.

Figure: QElectroTech ellipse properties panel

Note

If the selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties

Ellipse properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.
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1. Select the border from the ellipse which should be edited.

2. Press Ctrl + e to display the ellipse properties PopUP window.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Polygon

Create polygon

Note

To draw more easily, the folio grid can be displayed from Display > Display the grid or from toolbar icon .

The polygon can only be added to the workspace by toolbar.

1. Select the icon  from the toolbar to add a polygon.

2. Draw connected lines by simple click on the beginning and end point from each line.

3. Doble Click on the end vertex/point from the polygon.

Note

At everytime from the polygon creation, the previous line can be deleted without stopping the creation process.

• Right click will delete the previous line without losing all previous work.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

Polygon properties

A polygon is a plane figure generated by a finite number of line segments connected. When the initial and end line
segments from the polygon are connected, the polygon defines a closed area.

When the polygon do not define a closed area, the properties from the polygon object are the same as a line object.

When the poligon defines a closed area, the Closed polygon check button from the polygon properties panel is
selected, the polygon object has the same propertias as a rectangle object.

Note

If the initial and the end line segments from the polygon are not connected when the Closed polygon check
button is selected, a new line segment which connects both segments will be automatically generated.

The polygon properties can be displayed from menu bar, by right click on one polygon edge/line, from selection
properties panel and using keyboard shortcut.
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Polygon properties from menu bar

1. Select one of the edges/lines from the polygon which should be edited.

2. Select Edit > Edit the selected object menu item to display the polygon properties PopUP window.

Figure: QElectroTech edit menu

Polygon properties by right click

1. Right click on one of the edges/lines from the polygon which should be edited.

2. Select the option Edit the selected object to display the polygon properties PopUP window.

Figure: QElectroTech polygon selection PopUP window

Polygon properties from selection properties panel

1. Select one of the edges/lines from the polygon which should be edited and the properties from the polygon
will appear at selection properties panel.

Figure: QElectroTech Polygon properties panel

Note

If the selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties

Polygon properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.
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1. Select one of the edges/lines from the polygon which should be edited.

2. Press Ctrl + e to display the polygon properties PopUP window.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Add new point to polygon

1. Right click on the place from the edges/lines of the polygon where the new porint should be created.

2. Select the option Add a point to create the new point at the polygon.

Figure: QElectroTech polygon selection PopUP window

Delete point to polygon

1. Right click on the point from the polygon which should be deleted.

2. Select the option Delete this point to delete the point from the polygon.

Figure: QElectroTech polygon selection PopUP window

Working with pictures
QElectroTech allows adding and working with pictures at folios. The format from the picture should be PNG, JPG,
JPEG, SVG or Bitmap.

Figure: Cover Arduino project

Add picture

1. Select the icon  from toolbar to open the search file PopUP window.
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2. Select the picture at the corresponding directory.

3. Press Open button to add the picture.

4. Left click on the workspace area where the picture should be placed.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

Resize picture

1. Right click on the picture.

2. Select the option Edit the image to display the picture editor.

3. Choose the size scale desired.

4. Press Apply button to change the picture size.

Figure: QElectroTech picture editor

Note

The picture editor can also be displayed with double click on the picture using Ctrl + e shortcut keyboard.

Move picture

1. Left click on the picture.

2. Move the picture without releasing the button.

Note

The position from the picture can be locked to prevent involuntary movements, go to picture editor and check
the Lock Position button.

Select objects from workspace

Select one object

One object (element, conductor, text field, basic object and picture) from the workspace can be selected by a simple
left click on the object.
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Figure: QElectroTech schema

Select multiple objects

As many CAD tools, many objects (elements, conductors, text fields, basic objects and pictures) from workspace can
be selected in QElectroTech at the same time.

Select multiple objects using keyboard and mouse

QElectroTech allows selecting multiple objects from the workspace, combining the use of keyboard and mouse.

1. Select the first object.

2. Press Ctrl.

3. Select the rest of objects without releasing Ctrl.

Figure: QElectroTech schema

Select multiple objects by selecting area

QElectroTech allows selecting all objects from an area using the mouse to select the desired area.

1. Left click on the initial point from the rectangular area to be selected and displace the mouse without
releasing up to the end point.

Figure: QElectroTech selecting on workspace
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Select all objects

QElectroTech allows selecting all objet from workspace, all objects from the actived folio, at the same time. All
objects can be selected from menu bar, workspace or using the corresponding keyboard shortcut.

Select all objects from menu bar

1. Select Edit > Select All to select all objects from the activated folio.

Figure: QElectroTech Edit menu

Select all objects from workspace

As many other CAD tools, QElectroTech allows selecting all elements from the workspace, graphical area, using the
mouse.

1. Left click on the initial point from the rectangular area to be selected and displace the mouse without
releasing up to the end point.

Figure: QElectroTech selecting on workspace

Select all objects using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + a to select all objects from the activated folio.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.
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Select none

To be sure that any object is selected before any action, QElectroTech provides the option to unselect all objects
from the workspace. This option is useful for avoiding undesired changes such as the properties from an element.

The unselection of objects can only be done from menu bar.

1. Select Edit > Select none to unselect all selected object.

Figure: QElectroTech edit menu

Invert the selection

Some times is easier to select the objects from the workspace which are not interested for the desired action than
the objects which should be selected. For this reason, QElectroTech provides the option to invert the selection.

Inverting the selection can be done from menu bar or using the corresponding keyboard shortcut.

Invert selection from menu bar

1. Select the object/s from the activated folio which are not interested for the desired action.

2. Select Edit > Invert selection to invert the selection.

Figure: QElectroTech edit menu

Invert selection using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object/s from the activated folio which are not interested for the desired action.

2. Press Ctrl + i to invert the selection.

Schema

171

file:///home/hude/Documents/interface/workspace.html
file:///home/hude/Documents/element/properties/index.html
file:///home/hude/Documents/interface/menu_bar.html
file:///home/hude/Documents/interface/workspace.html
file:///home/hude/Documents/interface/menu_bar.html
file:///home/hude/Documents/schema/select/index.html
file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/schema/select/index.html
file:///home/hude/Documents/folio/index.html


Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Copy object
QElectroTech allows copying objects (element, conductor, text field, basic object and picture) to paste them at the
same folio or at different folio and/or project later.

Note

Multiples objects can be copied at the same time selecting multiple objects.

Warning

The element would suffer data losses if the intention is to paste it at different project.

Copying objects can be done from menu bar, toolbar, by right click on the object and using the corresponding
keyboard shortcut.

Copy object from menu bar

1. Select the object/s which should be copied.

2. Select Edit > Copy menu item to copy the object.

Figure: QElectroTech edit menu

Copy object from toolbar

1. Select the object/s which should be copied.

2. Select the icon  from toolbar to copy the object.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.
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Copy object by right click

1. Right click on the object which should be copied.

2. Select the option Copy to copy the object.

Figure: QElectroTech right click PopUP window

Copy object using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object/s which should be copied.

2. Press Ctrl + c to copy the object.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Cut object
QElectroTech allows cutting objects (element, conductor, text field, basic object and picture) to paste them at the
same folio or at different folio and/or project later.

Note

Multiples objects can be cut at the same time selecting multiple objects.

Warning

The element would suffer data losses if the intention is to paste it at different project.

Cutting objects can be done from menu bar, toolbar, by right click on the object and using the corresponding
keyboard shortcut.

Cut object from menu bar

1. Select the object/s which should be cut.

2. Select Edit > Cut menu item to cut the object.
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Figure: QElectroTech edit menu

Cut object from toolbar

1. Select the object/s which should be cut.

2. Select the icon  from toolbar to cut the object.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

Cut object by right click

1. Right click on the object which should be cut.

2. Select the option Cut to cut the object.

Figure: QElectroTech right click PopUP window

Cut object using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object/s which should be cut.

2. Press Ctrl + x to cut the object.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Paste object
QElectroTech allows pasting objects (element, conductor, text field, basic object and picture) which has already been
copied or cut at the same folio or at different folio and/or project.
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Note

Multiples objects can be pasted at the same time copying or cutting multiple objects.

Warning

The element would suffer data losses if the intention is to paste it at different project.

Pasting objects can be done from menu bar, toolbar, by right click at the workspace and using the corresponding
keyboard shortcut.

Paste object from menu bar

1. Select Edit > Paste menu item to paste at the active folio an object copied or cut previously.

Figure: QElectroTech edit menu

Paste object from toolbar

1. Select the icon  from toolbar to paste at the active folio an object copied or cut previously.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

Paste object by right click

1. Right click at the workspace area where the object should be pasted.

2. Select the option Paste Here to paste an object copied or cut previously.

Figure: QElectroTech right click PopUP window
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Paste object using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + v to paste at the active folio an object copied or cut previously.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Multiple paste
For making more eficient the schema creation, QElectroTech provides the feature multiple paste. This feature allows
copying and pasting one or more objects automating some object definition actions.

Figure: QElectroTech multiple paste

As a difference to the standard copy and paste feature, the multiple paste feature provides the following options:

• Copy and paste an onject (element, conductor, text field, etc.) multiple times in one action.

• Use QElectroTech auto-conection feature for element terminals which are at the same horizontal or vertical
line.

• Self-numbering of the copied element/s, the standard copy feature does not allow using auto-numbering
patterns.

• Self-numbering of the copied/created conductor/s, the standard copy feature does not allow using
auto-numbering patterns.

To copy and paste multiple times one or more object:

1. Select the object/s which should be copied.

2. Right click on the selected object/s.

Figure: QElectroTech element right click PopUP window

3. Select the option Multiple paste to display the multiple paste PopUP window.

Schema

176

file:///home/hude/Documents/github/folio/index.html
file:///home/hude/Documents/github/schema/copy.html
file:///home/hude/Documents/github/schema/copy.html
file:///home/hude/Documents/github/interface/menu_bar.html
file:///home/hude/Documents/github/schema/copy.html
file:///home/hude/Documents/github/schema/paste.html
file:///home/hude/Documents/github/schema/copy.html
file:///home/hude/Documents/github/schema/paste.html
file:///home/hude/Documents/github/schema/copy.html
file:///home/hude/Documents/github/schema/paste.html
file:///home/hude/Documents/github/element/index.html
file:///home/hude/Documents/github/conductor/index.html
file:///home/hude/Documents/github/schema/text/index.html
file:///home/hude/Documents/github/element/element_parts/terminal.html
file:///home/hude/Documents/github/element/index.html
file:///home/hude/Documents/github/schema/copy.html
file:///home/hude/Documents/github/conductor/index.html
file:///home/hude/Documents/github/schema/copy.html
file:///home/hude/Documents/github/schema/select/index.html


Figure: QElectroTech multiple paste PopUP window

4. Define the X and Y offset between original and copy/copies.

5. Define the number of copies desired.

6. Click the desired options about auto-connection, self-numebering of elements and self-numebering of
conductors.

7. Press OK Button to close the multiple paste PopUP window and create the copies.

Delete object
Choosing the correct element, conductor, text field, etc. from the beginning is always nice, even so, QElectroTech
allows deleting all type of object that can be add to the folios (element, conductor, text field, basic object and picture).

Note

Multiples objects can be deleted at the same time selecting multiples object.

Deleting objects can be done from menu bar, toolbar, by right click on the object and using the corresponding
keyboard shortcut.

Delete object from menu bar

1. Select the object/s which should be delete.

2. Select Edit > Delete menu item to delete the object.

Figure: QElectroTech edit menu

Delete object from toolbar

1. Select the object/s which should be deleted.

2. Select the icon  from toolbar to delete the object.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

Delete object by right click
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1. Right click on the object which should be deleted.

2. Select the option Delete to delete the object.

Figure: QElectroTech right click PopUP window

Delete object using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object/s which should be deleted.

2. Press delete to delete the object.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Rotate object
QElectroTech allows choosing the orientation from many object which are represented at the folio. The objects which
orientation can be choosed are the following:

• Element

• Picture

• Text field

QElectroTech does not allow all orientations for the objects mentioned before, only 4 different orientations are
possible: 0, 90, 180 and 270 degrees.

Note

QElectroTech only offers the posibility to rotate 90 degress on the clock direction.

• To rotate 180 degrees the actions should be repited once.

• To rotate 270 degrees the actions should be repited twice.

Note

Multiples objects can be rotated at the same time selecting multiples object

Rotating objects can be done from menu bar, toolbar, by right click on the object and using the corresponding
keyboard shortcut.

Rotate object from menu bar

1. Select the object which should be rotated.

2. Select Edit > Rotate menu item to rotate the object.
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Figure: QElectroTech Edit menu

Rotate object from toolbar

1. Select the object which should be rotated.

2. Select the icon  from toolbar to rotate the object.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

Rotate object by right click

1. Right click on the object which should be rotated.

2. Select the option Rotate to delete the object.

Figure: QElectroTech right click PopUP window

Rotate object using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object which should be rotated.

2. Press Space to rotate the object.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Object layer level
Overlaping of elements or pictures may occur at workspace, QElectroTech allows defining the level order from
elements and pictures at each folio.
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QElectroTech allows the following actions:

Icon Action Definition Keyboard shortcut

Bring to front Brings the selection (s) to front Ctrl + Shift + Home

Raise Aproachs the selection (s) Ctrl + Shift + Up

Lower Moves away the selection (s) Ctrl + Shift + Down

Send
backwards

Sends in the backwards the selection (s) Ctrl + Shift + End

Note

The layer level from multiples objects can be defined at the same time selecting multiple objects.

The level from each element or picture can be defined from menu bar, toolbar, by right click on the object and using
the corresponding keyboard shortcut.

Define object layer from menu bar

1. Select the object/s which layer level should be defined.

2. Select Edit menu and the desired action.

Figure: QElectroTech Edit menu

Define object layer from toolbar

1. Select the object/s which layer level should be defined.

2. Select the corresponding icon from toolbar (icons from above table) to realize the desired action.

Note

If the toolbar is not displayed, it can be displayed from Settings > Display > Depth

Define object layer by right click

1. Select the object/s which layer level should be defined.

2. Right click and select the desired layer definition action.
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Figure: QElectroTech element right click items

Define object layer using keyboard shortcut

As many other tools, QElectroTech is an applications which allows using keyboard shortcut.

1. Select the object/s which layer level should be defined.

2. Press the corresponding keyboard shortcut (keyboard shortcut from above table) to realize the desired
action.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Search
To find information inside a schema easily, QElectroTech provides a searching feature. This feature allows finding
automatically folios, elements, conductors and text fields (plain text) which contains a string at one of the properties.

To find an object which contains a string:

1. Go to search menu.

Figure: QElectroTech search menu

2. Write the string which should be search over the project in the text box from the menu.

3. Press Intro and QElectroTech will zoom and display the first object from the list of matches at the
workspace.

4. Press  or  button to zoom the next or previous object from the list of matches.

5. Press  button to refresh the search.

Note

If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item or using
Ctrl + f shortcut keyboard.

QElectrotech provides also some advanced properties for searching. Before searching, a filter can be dedined to
reduce the list of matches according the following criteria:

• Text fields (Plain text).

• Whole words (Text fields (Plain text), Conductor properties, Element properties, Folio properties)

To create an advanced search:

1. Go to search menu.

2. Press  button to display the filter tree.
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Figure: QElectroTech advanced search menu

3. Select the type of text to be searched (Plain text or Whole words) at the combobox from the right side of
the text box.

4. Click / unclick the button which selects Case sensitive.

5. From here, follow the steps from the standard search.

Replace

Replace text field content

QElectroTech provides the feature of searching and replacing text field content automatically. This option allows
replacing the complete content from a text field which contains the string searched. The string searched can be the
complete text field content or part of the text field content.

Note

If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace text field content over a project:

1. Search the string which should be replaced (Ex.: Folio).

Figure: QElectroTech search menu

2. Define the new text content at the replace text box (Ex.: Sheet reserve).

Figure: QElectroTech search menu

3. Select at the objects tree the text fields which content should be replaced.

4. Press Replace all button to replace the content from the selected text fields.

5. Press actualize  button to refresh the search.

Note

Replacing action can also be applied object by object. The button Replace will only apply the action to the
displayed object at the workspace. The buttons  and  can be used to display the previous and next text field
from the search result.
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Warning

The replacing feature from QElectroTech replaces the text field content completely. Changing the text field
content partly cannot be done.

Replace folio property

QElectroTech provides the feature of automatic searching of folios with an specific property for replacing folio
properties without the need of opening the folio properties PopUp window.

Note

If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace some folio properties:

1. Search the content which should identify the folio from which a property has to be changed.

Figure: QElectroTech search menu

2. Press the Folio button to display the folio properties PopUp window.

Figure: QElectroTech folio properties replace PopUp windows

3. Fill the text line box from the folio property/ies which should be changed.

Note

QElectroTech also allows deleting and making empty a filled property. Click at the right check
button from the folio property/ies which should be deleted.

4. Press Accept.

5. From the folios found at the search process, select the folios where the replace action have to be applied.
The selection can be made at the object tree from the search menu.

6. Press Replace all button to apply the replace action to all selected folios.
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Note

Replacing action can also be applied folio by folio. The button Replace will only apply the action to the displayed
folio at the workspace. The buttons  and  can be used to display the previous and next folio from the search
result.

Replace element property

QElectroTech provides the feature of automatic searching of element with an specific property for replacing element
properties without the need of searching the element manually arround the project.

Note

If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace some element properties:

1. Search the property (Manufacturer, Lable, etc.) which identifies the element from which a property has to
be changed.

Figure: QElectroTech search menu

2. Press the Element button to display the element properties PopUp window.

Figure: QElectroTech element properties replace PopUp windows

3. Fill the text line box from the element property/ies which should be changed.

Note

QElectroTech also allows deleting and making empty a filled property. Click at the cliked button
from the element property/ies which should be deleted.

4. Press Accept.

5. From the elements found at the search process, select the elements where the replace action have to be
applied. The selection can be made at the object tree from the search menu.

6. Press Replace all button to apply the replace action to all selected elements.

Schema

184

file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/interface/workspace.html
file:///home/hude/Documents/folio/index.html
file:///home/hude/Documents/element/index.html
file:///home/hude/Documents/element/properties/index.html
file:///home/hude/Documents/element/properties/index.html
file:///home/hude/Documents/element/index.html
file:///home/hude/Documents/interface/search_menu.html
file:///home/hude/Documents/element/properties/index.html
file:///home/hude/Documents/schema/search.html
file:///home/hude/Documents/element/index.html
file:///home/hude/Documents/element/properties/index.html
file:///home/hude/Documents/element/properties/index.html
file:///home/hude/Documents/element/index.html
file:///home/hude/Documents/element/index.html
file:///home/hude/Documents/interface/search_menu.html
file:///home/hude/Documents/element/index.html


Note

Replacing action can also be applied element by element. The button Replace will only apply the action to the
displayed element at the workspace. The buttons  and  can be used to display the previous and next
element from the search result.

Replace conductor property

QElectroTech provides the feature of automatic searching of conductor with an specific property for replacing
conductor properties without the need of searching the conductor manually arround the project.

Note

If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace some conductor properties:
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1. Search the property (Manufacturer, Lable, etc.) which identifies the conductor from which a property has to
be changed.

Figure: QElectroTech search menu

2. Press the Conductor button to display the conductor properties PopUp window.

Figure: QElectroTech conductor properties replace PopUp windows

3. Fill the text line box from the conductor property/ies which should be changed.

Note

QElectroTech also allows deleting and making empty a filled property. Click at the cliked button
from the conductor property/ies which should be deleted.

4. Press Accept.

5. From the conductors found at the search process, select the conductors where the replace action have to
be applied. The selection can be made at the object tree from the search menu.

6. Press Replace all button to apply the replace action to all selected conductors.

Note

Replacing action can also be applied conductor by conductor. The button Replace will only apply the action to
the displayed conductor at the workspace. The buttons  and  can be used to display the previous and next
conductor from the search result.

Advanced replace

QElectroTech provides the possibility to define a string and replace if for a new defining some conditions:

a. Type of object.

b. Object property with the defined value.

c. Filtering folio, type of element, etc.
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Note

If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace text information from project objects:1. Press advanced button to display advanced replace PopUp window.

2. Define QElectroTech object type from Who combobox (Ex.: Element).

Figure: QElectroTech advanced replace PopUp window

3. Define object property type from What combobox (Ex.: Manufacturer).

Figure: QElectroTech advanced replace PopUp window

4. Define the property value which should be replaced in the Replace text box (Ex.: SIEMENS).

5. Define the new property value at the replace text box in the By text box (Ex.: SCHNEIDER).
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Figure: QElectroTech advanced replace PopUp window

3. Press OK button to storage the desired replacing conditions.

4. Filter in the object tree the folios where the action should be applied.

Figure: QElectroTech search menu element properties PopUP window

6. Press Replace all button to apply the replace action.

Drawing

Design mounting plate
QElectroTech is not only a tool for diagrams and shemas, QElectroTech allows also drawing 2D drawings. Electrical
boxes, buttons, switches, screens and any other type of components can be drawn at the workspace.

2D drawings from electrical component can be created at the element editor as elements. After the creation of
component drawings, assembled panel drawings can be created introducing the elements at the workspace. At the
category Graphics from QET collection some common electrical components front views are provided as elements.

Note

For more information about how to create elements, refer to Create or edit element section.

For more information about how to introduce elements at workspace, refer to Working with element section.

The advantage of drawing mounting plates using QElectroTech and not with a different CAD tool is the posibility to
create links between the elements. A link between the elements which represents the electrical component at the
schema and the elements which represents the component at the drawing will reduce the future effort; the effort from
the manufacturing, intallation and maintenace phase of the project.
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Figure: QElectroTech Mounting plate example

Design Local Control Panel (LOP)
QElectroTech is not only a tool for diagrams and shemas, QElectroTech allows also drawing 2D drawings. Electrical
boxes, buttons, switches, screens and any other type of components can be drawn at the workspace.

2D drawings from electrical component can be created at the element editor as elements. After the creation of
component drawings, assembled panel drawings can be created introducing the elements at the workspace. At the
category Graphics from QET collection some common electrical components front views are provided as elements.

Note

For more information about how to create elements, refer to Create or edit element section.

For more information about how to introduce elements at workspace, refer to Working with element section.

The advantage of drawing control panels using QElectroTech and not with a different CAD tool is the posibility to
create links between the elements. A link between the elements which represents the electrical component at the
schema and the elements which represents the component at the drawing will reduce the future effort; the effort from
the manufacturing, intallation and maintenace phase of the project.
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Figure: QElectroTech Local Control Panel example

Reports

Summary

Create summary

A project can be a group of folios, QElectroTech provides the possibility to make a summary, project index, which
shows the information from the different folios. QElectroTech allows creating the project summary automatically.
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Figure: QElectroTech list of folios

To create a project summary:

1. Activate the folio where the summary table has to be created in the workspace.

2. Select Project > Add a summary to display the configuration PopUp window of the summary creator.

Figure: QElectroTech project menu

3. Go to Display tab to define display table properties.

4. Define the Table name which will identify the table.

5. Configure the display table settings (header and table cells properties, auto adjustment of table size, etc.).
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Figure: QElectroTech project menu

6. Go to Content tab to define table columns.

7. Modify the table content using the following commands:

Icon Action Keyboard shortcut

Move up this field

Add field to display list Double click on field at available list

Remove field from display list Double click on field at display list

Move down this field

Figure: QElectroTech project menu

Note

The content request configuration can be saved and chosen from Configuration section to increase
working efficiency.

QElectroTech is working with SQLite database, summary table content can also be defined by SQL
query.

8. Once the desired configuration is defined, press OK to create summary tables.

Note

The project summary can be created, modified and updated at any time.
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Edit summary

The summary properties can only be displayed from selection properties panel once the summary table has been
selected at workspace.

Figure: QElectroTech summary properties panel, display tab

Note

If the selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties.

Summary geometry and line

Figure: QElectroTech summary geometry and lines properties

The Geometry and lines section from the summary properties allows defining:

• Summary table position (coordinates X and Y) in the folio.

• Maximum number of table rows.

• Adjust the size of the table to the folio, automatic margin definition.

• Define previous summary table, property to be used if the number of folios is higher than the maximum
number of rows defined.

Note

If the number of folios is higher than the maximum number of rows defined, each summary table has to have a
Table name defined. Without Table name, the link between tables cannot be defined.

Header

Figure: QElectroTech summary header properties

The Header section from the summary properties allows defining:
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• Top, bottom, left and right margin in the header cells.

• Text alignment in the header cells.

• Text font of the table header.

Figure: QElectroTech summary table text font

Table

Figure: QElectroTech summary table properties panel

The Table section from the summary properties allows defining:

• Top, bottom, left and right margin in the table cells.

• Text alignment in the table cells.

• Text font of the table.

Figure: QElectroTech summary table text font

Content request

The folio properties to be displayed at the summary tables, the columns information, can be modified and
re-organized at any time.

To modify the content request form the summary:

1. Select one of the tables from the summary to display the summary properties at selection properties panel.

2. Go to Content tab.
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Figure: QElectroTech summary properties panel, content tab

3. Click Request button to display the content configuration PopUp window.

4. Modify the table content using the following commands:

Icon Action Keyboard shortcut

Move up this field

Add field to display list Double click on field at available list

Remove field from display list Double click on field at display list

Move down this field

Figure: QElectroTech summary properties content request PopUp window

Note

The content request configuration can be saved and chosen from Configuration section to increase
working efficiency.

QElectroTech is working with SQLite database, summary table content can also be defined by SQL
query.

5. Once the desired configuration is defined, press OK to apply changes.

Reload summary

When any folio is added or any folio property is edited, the changes are not updated at the summary automatically.
To update the folio properties at the summary, the summary has to be reload.

To reload the summary:

1. Select the summary table, or one of the summary tables if there is more than one, to display the summary
properties at selection properties panel.

2. Go to Content tab.

3. Click  Reload button to update folio properties at summary.
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Figure: QElectroTech summary properties panel, content tab

Nomenclature

Create nomenclature

A project is a combination / assembly of elements / components, QElectroTech provides the feature to create a
nomenclature, also known as Bill Of Materials (BOM), which shows the information about the different elements /
components. QElectroTech allows creating the nomenclature automatically.

Figure: QElectroTech Bill Of Materials (BOM)

To create a project nomenclature:

1. Activate the folio where the nomenclature table has to be created.

2. Select Project > Add a nomenclature to display the configuration PopUp window of the nomenclature
creator.

Figure: QElectroTech project menu

3. Go to Display tab to define display table properties.

4. Define the Table name which will identify the table.

5. Configure the display table settings (header and table cells properties, auto adjustment of table size, etc.).
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Figure: QElectroTech project menu

6. Go to Content tab to define table columns.

7. Modify the list of information to be displayed according the commands of the following table.

Icon Action Keyboard shortcut

Move up this field

Add field to display list Double click on field at available list

Remove field from display list Double click on field at display list

Move down this field

Figure: QElectroTech project menu

Note

The content request configuration can be saved and chosen from Configuration section to increase
working efficiency.

QElectroTech is working with SQLite database, nomenclature table content can also be defined by SQL
query.

8. Define the filtering parameters (Filter by and type of elements).

9. Once the desired configuration is defined, press OK to create nomenclature tables.

Note

The project nomenclature can be created, modified and updated at any time.
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Edit nomenclature

The nomenclature properties can only be displayed from selection properties panel once the summary table has
been selected at workspace.

Figure: QElectroTech nomenclature properties panel, display tab

Note

If the selection properties panel is not displayed, it can be displayed from Settings > Display > Selection
properties.

Nomenclature geometry and line

Figure: QElectroTech summary geometry and lines properties

The Geometry and lines section from the summary properties allows defining:

• Nomenclature table position (coordinates X and Y) in the folio.

• Maximum number of table rows.

• Adjust the size of the table to the folio, automatic margin definition.

• Define previous nomenclature table, property to be used if the nomenclature table is not fitting in one folio.

Note

If the table is not fitting in one folio, each nomenclature table has to have a Table name defined. Without Table
name, the link between tables cannot be defined.

Header

Figure: QElectroTech nomenclature header properties

The Header section from the nomenclature properties allows defining:
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• Top, bottom, left and right margin in the header cells.

• Text alignment in the header cells.

• Text font of the table header.

Figure: QElectroTech nomenclature table text font

Table

Figure: QElectroTech nomenclature table properties panel

The Table section from the nomenclature properties allows defining:

• Top, bottom, left and right margin in the table cells.

• Text alignment in the table cells.

• Text font of the table.

Figure: QElectroTech nomenclature table text font

Content request

The element properties to be displayed at the nomenclature table, the columns information, can be modified and
re-organized at any time.

To modify the content request from nomenclature:

1. Select one of the tables from the nomenclature to display the nomenclature properties at selection
properties panel.

2. Go to Content tab.
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Figure: QElectroTech nomenclature properties panel, content tab

3. Click Request button to display the content configuration PopUp window.

4. Modify the list of information to be displayed by the commands of the following table.

Icon Action Keyboard shortcut

Move up this field

Add field to display list Double click on field at available list

Remove field from display list Double click on field at display list

Move down this field

Figure: QElectroTech nomenclature properties content request PopUp window

Note

The content request configuration can be saved and chosen from Configuration section to increase
working efficiency.

QElectroTech is working with SQLite database, nomenclature table content can also be defined by SQL
query.

5. Once the desired configuration is defined, press OK to apply changes.

Reload nomenclature

When any element is added or any element property is edited, the changes are not updated at the nomenclature
automatically. To update the element properties at the nomenclature, the nomenclature has to be reload.

To reload the nomenclature:

1. Select the nomenclature table, or one of the nomenclature tables if there is more than one, to display the
nomenclature properties at selection properties panel.

2. Go to Content tab.
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3. Click Reload  button to update element properties at nomenclature.

Figure: QElectroTech nomenclature properties panel, content tab

Conductor list
Feature still not available in QElectroTech 0.8

I/O list
Feature still not available in QElectroTech 0.8

Export and print

Print project
The active project can be printed from menu bar, toolbar and using the corresponding keyboard shortcut.

Warning

Check that the active project is the project that should be printed.

Print project from menu bar

1. Select File > Print menu item to open the printing PopUP window.

2. Click Print to a physical printer check button.

Figure: QElectroTech printing PopUP window

3. Press Ok Button to open the selection printer PopUp window.

4. Select printer and the preview printing PopUP window will be displayed.

Figure: QElectroTech printing options PopUP window
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5. Select the folios which should be printed.

Figure: QElectroTech printing preview PopUP window

6. Select the printing option.

7. Press Print Button.

Note

• If the folio list is not displayed, select the icon  from the toolbar.

• If the printing options panel is not displayed, select the icon  from the toolbar.

Print project from toolbar

1. Select the icon  from the toolbar to open the printing PopUP window.

2. Follow the steps defined at the printing project from menu bar section.

Note

If the toolbar is not displayed, it can be displaed from Settings > Display > Tools

Print project using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + p to open the printing PopUP window.

2. Follow the steps defined at the printing project from menu bar section.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Seealso

QElectroTech allows predefining printing settings for reducing the working configuration effort each time that a
project have to be printed, refer to printing settings section for more information.
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Create a PDF from a project
The active project can be exported to PDF from the menu bar, toolbar and using the corresponding keyboard
shortcut.

Warning

Check that the active project is the project that should be printed.

Note

The current version from QElectroTech, version 0.7, does not allow keeping the element links on the PDF
document.

Export project to PDF from menu bar

1. Select File > Print menu item to open the printing PopUP window.

2. Select Print to PDF a file check button.

3. Select the directory where to save the PDF file

Figure: QElectroTech printing PopUP window

4. Press Ok Button to open the preview printing PopUP window.

Figure: QElectroTech printing preview PopUP window

5. Select the folios that should be printed.

6. Select the printing option.

7. Press Print Button.

Note

• If the folio list is not display, select the icon  from the toolbar.

• If the print options panel is not display, select the icon  from the toolbar.
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Export project to PDF from toolbar

1. Select the icon  from the toolbar to open the printing PopUP window.

2. Follow the steps defined at the printing project from menu bar section.

Note

If the toolbar is not displayed, it can be displaed from Settings > Display > Tools

Export project to PDF using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + p to open the printing PopUP window.

2. Follow the steps defined at the printing project from menu bar section.

Seealso

For more information about QElectroTech keyboard shortcuts, refer to menu bar section.

Export schema
QElectroTech allows exporting the different folios to many type of formats: PNG, JPEG, Bitmap, SVG and DWX.1. Select File > Export menu item to display exporting PopUP window.

Figure: QElectroTech file menu

Note

QElectroTech allows using keyboard shortcuts to increase the working efficiency.

1. Press Ctrl + Shift + X to display exporting PopUP window.

For more information about QElectroTech keyboard shortcut, refer to menu bar section.

2. Choose the folios you wish to export and specify their size.
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Figure: QElectroTech export PopUP window

3. Choose target directory and format.

Figure: QElectroTech exporting formats combo box

4. Choose rendering options.

Figure: QElectroTech rendering options

5. Press Export button to create the files.

QElectroTech creates one file for each folio choosed at the target directory defined.

Seealso

QElectroTech allows predefining exporting settings for reducing the working configuration effort each time that a
project have to be exported, refer to export settings section for more information.

Export nomenclature
QElectroTech allows creating a CSV file which contains a list of all elements from the active project. The CSV file
can be opened and edited with tools as LibreOffice Calc.

The different field properties are listed by columns and the elements are ordered by folio.

To export the nomenclature list to CSV file:

1. Select Project > Export to CSV menu item to open the exporting parameter PopUP window.

Figure: QElectroTech project menu

2. Modify the list of information to be exported by the commands of the following table.
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Icon Action Keyboard shortcut

Move up this field

Add field to export list Double click on field at available list

Remove field from export list Double click on field at export list

Move down this field

Figure: QElectroTech export nomenclature PopUp window

3. Define the filtering parameters (Filter by and type of elements).

Note

The content and filtering request configuration can be saved and chosen from Configuration section to
increase working efficiency.

QElectroTech is working with SQLite database, summary table content can also be defined by SQL
query.

4. Define page layout parameters (include table header and type of format).

5. Press OK button to apply exporting parameters and display the Save As PopUp window.

6. Choose target directory and file name.

7. Press Save button to create the file with extension .csv.

Export wires
QElectroTech allows creating a CSV file which contains a list of all conductors / wires from the project. The CSV file
can be opened and edited with tools as LibreOffice Calc.

The different field properties are listed by columns and the conductors / wires are ordered by folio.

To export the conductors / wires list to CSV file:

1. Select Project > Export the list of names of wires menu item to open the exporting PopUP window.

2. Choose target directory and file name.

3. Press Save button to create the file with extension .csv.
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Figure: QElectroTech project menu

Export internal project database
QElectroTech allows creating a SQLite database which contains the project database.

To export the internal project database to a .sqlite file:

1. Select Project > Export the internal project database menu item to open the exporting PopUP window.

2. Choose target directory and database name.

3. Press Save button to create the file with extension .sqlite.

Figure: QElectroTech project menu

Annex

Default QElectroTech variables
To systematize title block templates and allow auto numbering of elements, conductors and folios; QElectroTech
provides the posibility to work with variables.

The variables are used to define the content of text field and properties from elements, folios and conductors.
Depending on the conditions during the creation of the object (folio, element, conductor, etc,) The variable of the text
or property field is replaced by a different value.

A property is identified as a string which starts with the symbol %. The default variables provided by ElectroTech can
be found at this section.

General project variables

The following variables are global variables which can be used to create title block templates.

• % {projecttitle}: Project title

• % {projectpath}: Project path

• % {projectfilename}: Project file name

• % {saveddate}: File saving date

• % {filename}: Project file name

• % {savedfilename}: Registered file name

• % {savedfilepath}: Saved file path

• % {savedtime}: File saving time

• % {folio-total}: Total number of folios in the project

• % {version}: Software version

• % {machine}: Project functional group name

variables related to folio

The following variables are specific variables for each folio. They can be used to create title block templates.

• % {folio-id}: Folio position in the project
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• % {title}: Folio title

• % {author}: Folio author

• % {date}: Folio date

• % {folio}: Folio information (Label)

• % {indexrev}: Folio revision index

• % {locmach}: Name of the location in the project functional group

• % {previous-folio-num}: Number previous folio

• % {next-folio-num}: Number next folio

variables related to element

The following variables are specific variables for each element. They can be used to create auto numbering patterns.

• % {F}: Label from the folio where the element can be found

• % {f}: Number from the folio where the element can be found

• % {M}: Plant variable from the folio where the element can be found

• % {LM}: Location variable of the folio where the element can be found

• % {l}: Folio line number from the workspace where the element can be found

• % {c}: Folio column number from the workspace where the element can be found

• % {id}: Folio position in the project (Schema number)

variables related to conductor

The following variables are specific variables for each conductor. They can be used to create auto numbering
patterns.

• % {F}: Label from the folio where the conductor can be found

• % {f}: Number from the folio where the conductor can be found

• % {M}: Plant variable from the folio where the conductor can be found

• % {LM}: Location variable of the folio where the conductor can be found

• % {l}: Folio line number from the workspace where the conductor can be found

• % {c}: Folio column number from the workspace where the conductor can be found

• % {id}: Folio position in the project (Schema number)

QElectroTech text font
To define the text font at the Select font PopUP window:

1. Search for the font using the searching box or using the scrollbar from right side.

2. Click on the text font in the list box.

3. Defin font size by horizontal scrollbar, defining the size in the text box or using +/- buttons.
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Figure: QElectroTech select font PopUp window

Color selection

Basic color

QElectroTech provides a Select color PopUp window with some basic colors.

Figure: QElectroTech basic color selector

To select a color:

1. Click on the desired color.

2. Press Select button.

The Select color PopUp window is also provided with a custom section where the colors defined in the past are
stored.

Custom color

QElectroTech allows customizing colors by defining the HTML code.

To define a custom color:

1. Press the buttom + from the custom color section of the Select color PopUp window.

2. Define the HTML code of the desired color in the text box.

Figure: QElectroTech custom color selector

3. Press Select button to add the new color to the custom section of the Select color PopUp window.
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Note

The custom color can also be defined visually:

1. The color scale can be defined by the scrollbar placed at left side.

2. The grays scale can be defined by a cursor click on the color scale.

Seealso

For more information about HTML color code, refer to online resources as:

https://htmlcolorcodes.com/

here is the pdf version pdf
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